Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® World™ Development

Reply
New Developer
Posts: 66
Registered: ‎11-23-2009
My Device: Not Specified

How to set maximum/highest supported OS in App World?

Hello,

 

I have an app that works in 4.6 and 4.7 but does NOT work in OS 5.0+.

 

How do I restrict App World to not let people with OS 5.0 download my app? I see an option for minimum OS, but is there a setting for maximum supported OS?

Regular Contributor
Posts: 67
Registered: ‎03-23-2010
My Device: all BB 7 (incl. prototypes)
My Carrier: MTS-Ukraine

Re: How to set maximum/highest supported OS in App World?

I'm having the exact same question... any replies?

I know OTA, BES and Web Loader can detect os version but I'm not sure how to autofilter based on max os version in the App World.

Also, is there anyone who tried getjar.com for BB distribution, does that have this feature?

 

Highlighted
Trusted Contributor
Posts: 242
Registered: ‎03-16-2010
My Device: 9530

Re: How to set maximum/highest supported OS in App World?

 

I don't know much on the App World. But if the App World doesn't have the option you require, you application can test the OS version before execution. If the version is >= 5.0, inform the user about it.

Atleast that will let users understand that why your app is not working.

 

Hope it helps.

 

Regards,


--------------------------------------------------------------------------------
For any helpful answers give kudo's (star) to the helper.