Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® World™ Development

Reply
Developer
Posts: 264
Registered: ‎10-05-2010
My Device: Not Specified

Re: Multiple dynamic license web request coming in ...

Thanks Ryan. The acknowlegement and updates make all the difference.

 

I don't think a letting of executive blood will be necessary.

 

What I would like to see is more Internal RIM resources dedicated to mentoring the developers in this forum. I see the occasional posting by Mark Sohm but that's about it for RIM visibility. 

 

I know there are a lot of other topics in here. But I would certainly treat the development threads as a priority. The more productive you can make your developers, the more apps you will have in your store. Simple as that...

 

I've been fighting with certain "app launching" problems for months. I keep posting questions in this forum and do get the occasional response from the community. But to date, I have not been able to solve it. It is costing us both business (me and RIM). If there were more resources available to help, I might be selling 20% more apps. And RIM would be earning more commission.

 

At a potential $2 profit per app, 99% of the developers will never be able to afford per-incident support. So wouldn't it be nice if RIM could invest a little more resources in us.

 

Sounds like a great job for a couple of Waterloo co-op students. They can investigate the problems and then consult the Internal people for help. What a geat way to learn a platform? 

Developer
Posts: 229
Registered: ‎11-21-2009
My Device: Not Specified

Re: Multiple dynamic license web request coming in ...

PrecisionPete....

 

 

Send me a PM from your real email and I'll try to help you with the AppLaunch problem...

 

I've pretty much done them all Ui/Background/AlternateEntry/AutoStart/SystemModule...

 

Now I have a common framework that I just set properties and each new app launches

based on the property...all of the 20+ apps share the same framework.

 

Other than that - as a result of this "episode" of the license server going nuts - we have our

email server now declared a SPAM server on numerous networks...we send a welcome

message everytime we generate a license...last night some people got as many as 100

emails from us...as the AppWorld server requested 100 licenses...we were not set

up to ignore duplicates - plus it might be an upgrade and they don';t tell you this in

the POST....

 

Developer
Posts: 229
Registered: ‎11-21-2009
My Device: Not Specified

Re: Multiple dynamic license web request coming in ...

Ryan - you guys still have problems...I'm still getting repeat license requests...and I have customers getting cutoff in My World - they pay but get no product...and they are mad at us...

Highlighted
Developer
Posts: 76
Registered: ‎03-15-2010
My Device: 9800, 9630
My Carrier: Rogers

Re: Multiple dynamic license web request coming in ...

 

 

I'm not sure that this thread is a good place to bring up other issues, but .. We've also had problems like this. There are 2 issues which seem to make up 75% of our support emails:
1) Customer buys the app, license key is issued normally. Customer can see the license key and can click "Copy license" in app world. Customer is then told that a reboot is required, and on returning, the license key has disappeared from My World.

2) Customer buys the app, license key is issued normally from our side. They then receive a "Purchase Not Found" error when going back into My World and their license is lost.

Jason

 

Developer
Posts: 229
Registered: ‎11-21-2009
My Device: Not Specified

Re: Multiple dynamic license web request coming in ...

 

BINGO....here's just 1 from this morning...same as you:

 

 

I purchased this app but in My World  it shows as "purchase not found." I did receive an email conformation of payment. I need to get this app working or have the cost refunded. Please respond to this email and let me know how to proceed.

 

Thank you,

Michelle ******

Sent via BlackBerry from T-Mobile

Developer
Posts: 264
Registered: ‎10-05-2010
My Device: Not Specified

Re: Multiple dynamic license web request coming in ...

[ Edited ]

Ryan... It's better but not fixed.

 

Looking at my database, I do not get the repeating requests anymore. I do however get old customers requesting new keys with an invalid decimal PIN. 

 

The request still fail... though this time only once. I assume this means that whatever the customer did to request the key is also still failing. They are probably still frustrated.

 

Keep going. You're not out of the woods yet.

 

Please also do acknowledge that you know this and let us know what your are doing to address it. We need to keep dealing with the customer complaints...

 

I should add that in my case, 100% of the requests come from people that were already licensed in the past. Not sure if that help your investigation...

 

CORRECTION: I found a couple that failed and I had to create a key by hand. So the problem is not confined to previous customers...

 

Thanks

Peter

BlackBerry Development Advisor
Posts: 317
Registered: ‎03-13-2009
My Device: BlackBerry Z30
My Carrier: RIM

Re: Multiple dynamic license web request coming in ...

Hi precisionpete,

 

Thanks for verifying the multiple requests problem appears to be resolved on some level.

 

I'm looking into why the PINs are being sent in Decimal.  As some of the other threads on here mention this was fixed, then not fixed a few times.  We never should be sending users PINs in Decimal format, so I'm trying to button this up as well.

 

I'll update here when I have more information as to why we're still sending PINs in decimal.

 

Thanks,

 

Ryan

Developer
Posts: 264
Registered: ‎10-05-2010
My Device: Not Specified

Re: Multiple dynamic license web request coming in ...

Thanks Ryan. Maybe while we are on the topic...

 

Can you please verify for the record if those requests are supposed to come to us at all? i.e. what is the intended flow we should be expecting?

 

Of course... the initial purchase comes to us for a license key. 

 

But other than swapping devices (a PIN change), is it supposed to come back to us for the key again? Or is that part of the bug.

 

I ask this because I would like the stats in my databaase to match the official RIM stats so I can reconcile payments. If these requests are going to continue (with a correct PIN at least), I will have to recognize them as something different at me and.

 

I don't think any of this was dealt with in the AW API specs...

 

Thanks

Peter

BlackBerry Development Advisor
Posts: 317
Registered: ‎03-13-2009
My Device: BlackBerry Z30
My Carrier: RIM

Re: Multiple dynamic license web request coming in ...

Sure thing.

 

So, depending on the status of a License Key for this user on their device, it is normal to see the occasional requests for existing users. 

 

If the database does not have a License Key for a user, your server will get a new POST looking to populate the database and the users device with a License Key.  This also happens if the user changes devices (new PIN) as you mentioned.

 

In any of these post-purchase transactions, the one constant should be the transactionID.  Regardless of what the user changes their BlackBerryID email address too, or what device they switch to, the transcationID will remain the same. 

 

You should be able to use this transactionID to identify a new users vs. an existing user.

 

Let me know if this helps,

 

Ryan 

New Developer
Posts: 50
Registered: ‎01-30-2009
My Device: Not Specified

Re: Multiple dynamic license web request coming in ...

[ Edited ]

1) Customer buys the app, license key is issued normally. Customer can see the license key and can click "Copy license" in app world. Customer is then told that a reboot is required, and on returning, the license key has disappeared from My World.

2) Customer buys the app, license key is issued normally from our side. They then receive a "Purchase Not Found" error when going back into My World and their license is lost.

 

I've been having that problem for over a year and a half. App world support has been telling me it's only my app. (rolling eyes...)