Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® World™ Development

Reply
New Contributor
Posts: 2
Registered: ‎05-02-2013
My Device: Curve 9360 - Bold 990 - 7.1
My Carrier: Free
Accepted Solution

My App run on 7.1, not on 7.0

Hi everybody,

 

I just submitted my app on BB World and i have a problem just for 7.0 OS

 

In first, I published the app just for 7.1, and all works fine.

 

Thereafter, I wanted to let compatible the app for 7.0. So I build the cod file in Eclipe with 7.0 JRE, no errors, etc .. and finally the app was approved by Blackberry support.

 

The app still work on 7.1 but for the 7.0 user, they have the following issue when they try to launch this app, in a popup:

"Error starting App_Name: Class 'net.rim.device.api.system.Bitmap' not found."

and the app doesn't start.

 

I observed this issue on BlackBerry Curve 9360 and Bold 9900, but i think it's just linked to the OS Version 7.0 (on Bold 9900 and curve 9360 with 7.1 it's work)

 

If somebody have an idea about this issue ?

 

Thanks in advance.

 

MB

New Contributor
Posts: 2
Registered: ‎05-02-2013
My Device: Curve 9360 - Bold 990 - 7.1
My Carrier: Free

Re: My App run on 7.1, not on 7.0

I found the solution:

It's about the app weight. I don't know why an error appear only in 7.0 version but now I have just delete some unused files and it's ok no more error.

Very disconcerting because the pop up message absolutly does not relate with the real problem.

 

Hope it can help !

 

MB