Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® World™ Development

Reply
New Developer
Posts: 5
Registered: ‎01-23-2014
My Device: Bold 9780
My Carrier: (not active)
Accepted Solution

Package ID already in use An error occurred while saving release '1.1.0' to the database.

Hi,

I currently have an app named "Apa Doanya" (id 33020976) for BB 7 and below. Now I have created another version of it for BB10. To publish this BB10 version, I created a new app also named "Apa Doanya" (id 46317888), upload the bar file, but not yet submit the new app for review. Later I changed my mind, I want to release this BB10 version under my current app's name so that I can retain the current download numbers and ratings. So under my current app, I add a new release, upload the bar file and increment the version to 1.1.0. But I got an error when saving on step 5, it said:

Package ID already in use
An error occurred while saving release '1.1.0' to the database.

I tried several times but no luck. What caused it? Is it because I previously upload the bar file to another app (id 46317888)? Just to make sure, I remove that bar file from app 46317888, and upload a dummy cod file (so that the app can be saved). Then I repeat the the step above (add a new release, and so on) but I still got the same error.

Really appreciate any help.

-Rahmadi D-

Highlighted
Developer
Posts: 6,152
Registered: ‎07-05-2012
My Device: Playbook, Dev Alpha C, Z10 LE, Z30
My Carrier: Orange

Re: Package ID already in use An error occurred while saving release '1.1.0' to the database.

Welcome to the forums.

 

I recommend you contact vendor support to sort out your problem...

 

https://developer.blackberry.com/blackberryworld/vendor_support.html?eventId=8109


If you've been helped click on Like Button, if you've been saved buy the app. Smiley Happy

Developer of stokLocker, Sympatico and Super Sentences.
New Developer
Posts: 5
Registered: ‎01-23-2014
My Device: Bold 9780
My Carrier: (not active)

Re: Package ID already in use An error occurred while saving release '1.1.0' to the database.

Thanks, I emailed them as you suggested, but have not received any reply nor notification yet. I guess i will wait a little more time. Thanks.

BlackBerry Development Advisor
Posts: 15
Registered: ‎04-10-2013
My Device: BlackBerry z10
My Carrier: Telkomsel

Re: Package ID already in use An error occurred while saving release '1.1.0' to the database.

Hi Rahmadi,

 

Do you already solve the problem? let me know if you still have the issue.

 

Many thanks,

Erik Sanjaya

New Developer
Posts: 5
Registered: ‎01-23-2014
My Device: Bold 9780
My Carrier: (not active)

Re: Package ID already in use An error occurred while saving release '1.1.0' to the database.

Hi erik,
Thanks for reminding me Smiley Very Happy

Yes, the problem is now SOLVED. It was, I think, an error/bug on their part (vendor support), so they cleared the package id (I quote: "The package ID has been cleared.").

Thank you very much :-)

BlackBerry Development Advisor
Posts: 15
Registered: ‎04-10-2013
My Device: BlackBerry z10
My Carrier: Telkomsel

Re: Package ID already in use An error occurred while saving release '1.1.0' to the database.

Hi Rahmadi,

 

Thank you 

 

Best Regards,

Erik Sanjaya

New Contributor
Posts: 4
Registered: ‎03-21-2016
My Device: Z10
My Carrier: Telkomsel

Re: Package ID already in use An error occurred while saving release '1.1.0' to the database.

Hi, I'm having the same issue. I have submitted my app, but with series of images of a different brand device, so I got rejected. Now I've re-upload the images, create a new product, but always get that warning "Package ID already in use", even tho I have re-package my app using a different bbidtoken. Can someone please let me know, whats going on? Thank you Smiley Happy
BlackBerry Development Advisor
Posts: 236
Registered: ‎02-26-2013
My Device: BlackBerry Passport
My Carrier: Bell

Re: Package ID already in use An error occurred while saving release '1.1.0' to the database.

@samiajia please PM me your appID so I can take a closer look. If the package ID is already in use, then there is another app with the same signing keys and bundle name.

powerfully,
Bryan Van Engelen
BlackBerry World
New Contributor
Posts: 4
Registered: ‎03-21-2016
My Device: Z10
My Carrier: Telkomsel

Re: Package ID already in use An error occurred while saving release '1.1.0' to the database.

Hi Bryan,

 

Thank you for your reply. I ported my app from .apk to .bar. Where do I find the App ID?

 

Regards,

 

Aji

BlackBerry Development Advisor
Posts: 236
Registered: ‎02-26-2013
My Device: BlackBerry Passport
My Carrier: Bell

Re: Package ID already in use An error occurred while saving release '1.1.0' to the database.

Hi Aji,

 

1. Log into Vendor Portal

2. Select the application

3. Select details

4. Notice ID # under your vendor name in the top left corner

powerfully,
Bryan Van Engelen
BlackBerry World