Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® World™ Development

Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.

Posts: 1
Registered: ‎03-08-2011
My Device: Not Specified
Accepted Solution

Playbook signing- Company name with a comma

[ Edited ]

I am in the process of signing a webworks app for the playbook, and when I ran this:

./blackberry-keytool -genkeypair -keystore sigtool.p12 -storepass mypassword -dname "cn=Creative App Design, LLC" -alias author


I got this error:

keytool error: java.io.IOException: Incorrect AVA format

The only way I could find to get around this was to enter the company name without a comma. This allowed everything to run smoothly until I actually try to sign the app, and I receive this message:


barsigner error: server error: Code signing request failed because Common Name in developer certificate is not [Creative App Design  LLC].


The only thing I can think is that when I registered for the signed keys I registered under the company name with a comma, so it won't verify when I don't use a comma when generating the key. Do I need to re-register for keys under my company name without the comma, even though that's not what my actual company name is????

This whole process has been an incredible pain...

Posts: 6,541
Registered: ‎10-27-2010
My Device: HTC One, PlayBook, LE Z10, DE Q10
My Carrier: Verizon

Re: Playbook signing- Company name with a comma

You are correct.  Punctuation is not allowed in the CN name and that name needs to match what was used during registration for the keys.  You will probably need to get a new set of keys with a simplier organization name.

Posts: 40
Registered: ‎11-21-2010
My Device: 9630
My Carrier: Verizon

Re: Playbook signing- Company name with a comma

You have got to be kidding. Blackberry will accept a submission with a comma in the CN and will issue the csj file, but when you try to create a certificate (or select an existing certificate) spelled EXACTLY THE SAME WAY, it bombs????


I'm having the same problem (Futurescale, Inc), as I'm sure every company with an 'Inc' after their company name will.


I also can't select my Thawte issued code-signing certificate that I paid for and sign all my AIR apps with.


However I've only tried this through the FB 4.0.1 IDE. I'm going to try it with the command line and see if that's possible.

Dungeon Joe - A Touch-focused Strategy Game http://dungeonjoe.com
Posts: 40
Registered: ‎11-21-2010
My Device: 9630
My Carrier: Verizon

Re: Playbook signing- Company name with a comma

No luck with the command line, unable to get the barsigner to work. It can't figure out where it's libraries are. I've done everything I can to point it in the right direction and there is no hope.



Dungeon Joe - A Touch-focused Strategy Game http://dungeonjoe.com