Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® World™ Development

Posts: 144
Registered: ‎08-18-2012
My Device: Blackberry Curve 8520
My Carrier: Vodafone

Please help me install BlackBerry JDE v5.0 in existing eclipse

[ Edited ]

I have presently BlackBerry JDE v7.0 installed in my eclipse Pulgin. Please help me install new BlackBerry JDE v5.0 in eclipse. I have used the following link:




But it doesn't  work. First of all it shows me the following "Problem Occurred" dialog:


Some sites could not be found. See the error log for more detail.
No repository found at http://www.blackberry.com/go/eclipseUpdate/3.6/java.
No repository found at http://www.blackberry.com/go/eclipseUpdate/5.1/java.


Then when I click on Finish, it shows me the following error while installing the update:


An error occurred while collecting items to be installed
session context wasSmiley Sadprofile=SDKProfile,
phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
Unable to read repository at
Read timed out



Please help. Thanks in advance.


Posts: 539
Registered: ‎11-09-2012
My Device: BlackBerry Z10
My Carrier: AIS Thailand

Re: Please help me install BlackBerry JDE v5.0 in existing eclipse

try reaching out to @BlackBerryDev for support

If you have an answer to your question then please click “Accept as Solution”
Click on the LIKE on the bottom right if the post deserves credit.
BB 8700 -> Bold 9000 -> Curve 8520 -> Bold 9700 -> Curve 9320 -> Bold 9900 -> BlackBerry Z10 + PlayBook 64 GB Wi-Fi