Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® World™ Development


Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.


Reply
Developer
Posts: 51
Registered: ‎01-24-2011
My Device: 9800
My Carrier: At&t
Accepted Solution

Problem! customers downloading the wrong version

as the tittle say i've been receiving mails from customers saying they just paid for one of my apps and downloaded but it doesn't work they can't find the theme, and when i go to check their bad review it says they downloaded the version for OS 5.0 and they were supposed to download the version for OS 6.0 what's wrong with that appworld? i went to check that all the versions have the correct devices. and they are ok !! Help Please 

-----------------------------------------------------------------------------------------------------
Be sure to click Kudos! for those who have helped you.
Click Solution? for posts that have solved your issue(s)!
Developer
Posts: 455
Registered: ‎03-04-2011
My Device: Paper cup

Re: Problem! customers downloading the wrong version

This happened to me also yesterday, someone got the file bundle for a higher OS than they had.
Developer
Posts: 51
Registered: ‎01-24-2011
My Device: 9800
My Carrier: At&t

Re: Problem! customers downloading the wrong version

In my case they downloaded a lower version than their current OS. Are customers able to choose wich version of the app-operative system they want to download ? Or does the system recognize it?
-----------------------------------------------------------------------------------------------------
Be sure to click Kudos! for those who have helped you.
Click Solution? for posts that have solved your issue(s)!
Highlighted
Developer
Posts: 1,452
Registered: ‎11-06-2009
My Device: Torch 9810
My Carrier: WiFi

Re: Problem! customers downloading the wrong version

In theory App World should match the app OS version with the phone OS version.

 

In real life - well, it seems that it doesn't work sometimes



"When you become a level 3 developer, you learn to communicate over the ether. I'm told that level 5 developers are ascend into a higher level of existence beyond the physical realm." gord888 @ crackberry
Developer
Posts: 455
Registered: ‎03-04-2011
My Device: Paper cup

Re: Problem! customers downloading the wrong version

They can't choose, each bundle is set for a minimum OS or greater, and it auto-selects.

 

This is a problem for devices that may have an older or newer OS.

 

For example, the 8520 largely has either 4.6 or 5.0.  Say your app has 4.6 and 5.0 versions.  If you set 8520 compatibility for both versions, App World won't approve the release until you set it compatible with only 4.6.  They've contacted me about this so many times, and don't seem to allow one device to be set compatible with more than one file bundle.  You have to set compatibility to the device's original OS.

 

Problem is, that means all 8520's get the 4.6 version, and the ones with 5.0 don't get the 5.0 version which has more features enabled by 5.0.  I don't understand why you can't set one device compatible with multiple bundles, and it gets the highest one that can run on its current OS.  Then when the users upgrade the OS, their apps also get upgraded to the more advanced version.

 

Developer
Posts: 51
Registered: ‎01-24-2011
My Device: 9800
My Carrier: At&t

Re: Problem! customers downloading the wrong version

well my apps already have some time "up for sale" and nobody contacted me about not getting the right version or something.until now.... and i'm sure the app has been sold a few times for these versions thanks to the reports.

i guess just wait and see if it continues happening 

-----------------------------------------------------------------------------------------------------
Be sure to click Kudos! for those who have helped you.
Click Solution? for posts that have solved your issue(s)!
Developer
Posts: 51
Registered: ‎01-24-2011
My Device: 9800
My Carrier: At&t

Re: Problem! customers downloading the wrong version

ok for everyone having this issue too :

 

This is because devices will want to download thie highest Release that supports their device.  2.0 is greater than 1.0 so any deivce that is supported on both Release will get 2.0, not the older 1.0. 

 

With regards to Minimum OS, OS6.0 devices will download the OS5.0 bundle unless you have a bundle in the newest Release with a  Minimum OS of 6.0 to support those device models.

 

Thanks Ryan.

-----------------------------------------------------------------------------------------------------
Be sure to click Kudos! for those who have helped you.
Click Solution? for posts that have solved your issue(s)!