Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® World™ Development

Reply
Developer
Posts: 425
Registered: ‎03-17-2011
My Device: Developer
My Carrier: Telus

Vendor portal - Reports broken

Request for chart fails - chart is noit displayed, only the word "chart".

 

When  I click the link "Download Reports" or resubmit the request uning  the browser's refresh button, the following page is displayed:

 

CSRF request !!

Sorry!! Your request is considered intrusive. Please do not use browser back button Go Back.

 

I have tried using Chrome, Internet Explorer and the PlayBoook browser with same results in all.

 

 

 

 




_________________________
In the dark and need a sky map?
Discover What's up at App World.
Follow What's up on Facebook

Developer
Posts: 6,473
Registered: ‎12-08-2010
My Device: PlayBook, Z10
My Carrier: none

Re: Vendor portal - Reports broken

I came here to start a thread on the same topic... :-(

There's also a little popup progress dialog that appears for a fraction of a second on every request.

It seems a bit odd that, although they're going to have the site offline on Saturday to do maintenance, they went ahead and made some significant change just now that broke the whole thing...

Peter Hansen -- (BB10 and dev-related blog posts at http://peterhansen.ca.)
Author of White Noise and Battery Guru for BB10 and for PlayBook | Get more from your battery!
Developer
Posts: 6,473
Registered: ‎12-08-2010
My Device: PlayBook, Z10
My Carrier: none

Re: Vendor portal - Reports broken

In case it's relevant, note that CSRF means "Cross-Site Request Forgery" and in this context the csrfToken is something they're using to prevent such forged requests as a protection mechanism. A good thing to do, when done properly...

Peter Hansen -- (BB10 and dev-related blog posts at http://peterhansen.ca.)
Author of White Noise and Battery Guru for BB10 and for PlayBook | Get more from your battery!
BlackBerry Development Advisor
Posts: 317
Registered: ‎03-13-2009
My Device: BlackBerry Z30
My Carrier: RIM

Re: Vendor portal - Reports broken

Hi All,

 

We're aware of this problem and are investigating to resolution. 

Developer
Posts: 425
Registered: ‎03-17-2011
My Device: Developer
My Carrier: Telus

Re: Vendor portal - Reports broken


peter9477 wrote:

There's also a little popup progress dialog that appears for a fraction of a second on every request.
.

The new pop-up justg says "Loading... please wait". It oinly stays up long enough to read in the PB Browser. It is just an unreadable blip on my desktop PC.

 

At least this latest problem caused me to find out about methods to thwart cross-site request forgery. Looks to me like RIM has outsmarted themselves in an attempt to stop third parties from bypassing their official form for getting reports and charts.

_________________________
In the dark and need a sky map?
Discover What's up at App World.
Follow What's up on Facebook

Developer
Posts: 6,473
Registered: ‎12-08-2010
My Device: PlayBook, Z10
My Carrier: none

Re: Vendor portal - Reports broken

Maurice, the CSRF stuff is not generally intended for preventing third-party access like that. I doubt it would be useful for blocking anything like that, as it's merely a mechanism to ensure that you can't have "canned" URLs in other pages that, when clicked, submit requests to the vendor portal that might do damage or steal data.

Peter Hansen -- (BB10 and dev-related blog posts at http://peterhansen.ca.)
Author of White Noise and Battery Guru for BB10 and for PlayBook | Get more from your battery!
Developer
Posts: 1,632
Registered: ‎07-14-2008
My Device: Z10
My Carrier: Fido

Re: Vendor portal - Reports broken

I had this problem a few days ago.  If you just refresh the page the report will show up. It just needed sometime.

Developer
Posts: 374
Registered: ‎02-12-2011
My Device: Bold 9780
My Carrier: Wind Mobile

Re: Vendor portal - Reports broken

It was a good few months while it lasted.
Developer
Posts: 1,452
Registered: ‎11-06-2009
My Device: Torch 9810
My Carrier: WiFi

Re: Vendor portal - Reports broken

There was a maintenance this morning. As usual the results of it will echo for months...



"When you become a level 3 developer, you learn to communicate over the ether. I'm told that level 5 developers are ascend into a higher level of existence beyond the physical realm." gord888 @ crackberry
Developer
Posts: 120
Registered: ‎03-13-2012
My Device: Playbook, Dev Alpha C, Q10, Z10, Z30
My Carrier: T-Mobile

Re: Vendor portal - Reports broken

I just tried it.  Both the scheduled report and the browser report.  They seem to be working fine now.

 

I had the same problem a few hours ago.