Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z10

Posts: 1
Registered: ‎03-05-2013
My Device: BlackBerry 9810
My Carrier: Etisalat

BB Z10 and MS Exchange Server 2010

Hello, At the moment I am using BlackBerry Torch 9810. I am plannig to buy BlackBerry Z10 soon (in fact cant wait to buy one) I have a trivial issue though, our exchange server administrator is saying that its not possible to use Z10 for Exchange Server 2010 emails. Can you please let me know whether BB Z10 can be used for email with Exchange Server 2010. Thanks a lot in advance!
Posts: 4,285
Registered: ‎07-26-2010
My Device: Q10/Q5/Z10/9930/9860/9310

Re: BB Z10 and MS Exchange Server 2010

Hey nilbos,

Welcome to the BlackBerry Support Community Forums.


Thanks for the question.


The BlackBerry Z10 will integrate emails from Microsoft Exchange Server 2010 as long as ActiveSync is enabled from the server.


Let me know if you have any more questions.





Come follow your BlackBerry Technical Team on Twitter! @BlackBerryHelp

Be sure to click Like! for those who have helped you.

Click  Accept as Solution for posts that have solved your issue(s)!

Trusted Contributor
Posts: 166
Registered: ‎02-14-2013
My Device: Z10
My Carrier: Rogefs

Re: BB Z10 and MS Exchange Server 2010

Read all the post on email problems and you will not be buying a Z10. Stay away from the Z10 it is one big nightmare.
New Contributor
Posts: 2
Registered: ‎04-22-2013
My Device: Z10
My Carrier: T-Mobile

Re: BB Z10 and MS Exchange Server 2010

My BB 9780 connected with our MS Exchange 2010 server with not problems but I have spent hours trying to get my new Z10 to connect and it will not.

I get various errors, but result is same. "Unexpected Error", "Unable to contact Server"  for servername.domain.com, or "The server https://servername.domain.com for account (username@domain.com) is not responding. The server name in your account settings might be incorrect, or the server might be temporarily offline. Check your settings to make sure the server name is correct and try again."

I am the Administrator of our Exchange Server and have found nothing in posts to resolve my problem. ActiveSync work fine with iPhones, Various Android phone and older Blackberrys. What changed, and how do I make it work.