Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z10

New Member
Posts: 1
Registered: ‎03-20-2014
My Device: BBZ10
My Carrier: Digicel


A couple weeks ago, my Z10 started to behave funny.


BBM would suddenly have a large red exclamation mark stating that connection was lost. This only goes away after restarting the phone. Now, sometimes when I click on an app it doesn't open, any app at all, does not open. This only corrected after restarting as well.


In whatsapp, I would receive messages and can't see them when I go into the app itself.


I have restored the phone to factory settings almost 3 times now and the problem always occurs after a while. Now it is not working atall. It turns on, but does nothing past that.


Any help atall would be grateful.



Guru II
Posts: 21,824
Registered: ‎04-01-2008
My Device: BlackBerry PRIV; BlackBerry Z30, Z10 and Q10 w/OS; PlayBook w/OS
My Carrier: AT&T


I recommend doing a security wipe and NOT restoring your backup file.


To perform a Security Wipe please follow the instructions below. Be sure and use BB Link to make a full backup before proceeding with the wipe:


Once the wipe is complete you can restore your backup. Keep in mind that data in the backup may be the source of the original problem and restoring it may restore the problem, as well. To alleviate this I recommend not restoring the Settings portion of the backup.

1. Please thank those who help you by clicking the "Like" button at the bottom of the post that helped you.
2. If your issue has been solved, please resolve it by marking the post "Solution?" which solved it for you!