Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z10

Reply
Highlighted
New Contributor
Posts: 7
Registered: ‎12-08-2011
My Device: Torch 9800 and Playbook
My Carrier: Rogers

Can't Send Emails

I have been using BB for many years and never had this problem (but always had BIS).

 

I have an email address that is for my own website. mike@mywebsite.ca (that's not my actual website), and I can set it up using IMAP so that I can receive emails, but when I send an email it actually says that it sent, shows as sent on my server (webmail.mywebsite.ca), but it does not actually send them email.

 

I tried sending to five different emails and not one wnet through. I emailed the same addresses from  y computer (same setup as phone) and it worked perfectly.

 

I spoke with rogers and they said it had to be a settings problem with my phone and needed to contact my hosting company for correct settings. Hosting company could not figure it out and said maybe it was a problem with Blackberry, Blackberry forum said it could be problem with Rogers.

 

Anyone have any ideas? Again, everything works using IMAP except sending messages, shows as sent everywhere (on server and on Blackberry) but nobody is receiving the emails I send.

 

My hosting is with Canadianwebhosting.com if that helps anyone arrive at answer somehow.

 

Thanks

 

 

Forums Advisor I
Posts: 568
Registered: ‎02-05-2013
My Device: Blackberry Z10, Blackberry Playbook 64gb
My Carrier: Bell

Re: Can't Send Emails

I have a private web site for my business and private email accounts that run on their server. When I tried to setup the pop account it would't set it up. The cause of the problem is that the SMTP servers are being blocked by your service provider for your phone( read this KB29891) . The only way around for me was to use another SMTP server( I used my cable modem server smtp.broadband.rogers.com) for your outbound email. Later on I got the guy hosting my mail server to change the smtp server from port 25 to port 26 and that also worked.

 

 

New Contributor
Posts: 6
Registered: ‎02-16-2013
My Device: Z10
My Carrier: Telus

Re: Can't Send Emails

Unfortunately that's not it. I've tried it with both ports with no luck.

Forums Advisor III
Posts: 1,036
Registered: ‎02-07-2013
My Device: Z10
My Carrier: Rogers

Re: Can't Send Emails

You have to ask your email provider to open port 26 to the smtp server or it won't work.

Many providers open up smtp on port 225 as well so you could try that.

Or turn on ssl and use port 465.

Does your website have a c panel? If so you can go to the email settings there and it will tell you what the settings should be. If you have c panel and can't find it let me know and I can work on a step by step for you. Smiley Happy
-: DrewRead :-
Can't find an app on Blackberry World yet? Tweet the developer and ask when they will #GetWithBB10 !!
"Like it" if you like it. Smiley Happy
BlackBerry Employee
Posts: 750
Registered: ‎05-15-2008
My Device: Z10
My Carrier: Rogers

Re: Can't Send Emails


Cheers1981 wrote:

 

I have an email address that is for my own website. mike@mywebsite.ca (that's not my actual website), and I can set it up using IMAP so that I can receive emails, but when I send an email it actually says that it sent, shows as sent on my server (webmail.mywebsite.ca), but it does not actually send them email.

 


Are you saying that if you log onto your webmail from a computer after sending a message from the BlackBerry you can see the sent item there?  If so then the BlackBerry has successfully submitted the message to your webmail to send.

New Contributor
Posts: 6
Registered: ‎02-16-2013
My Device: Z10
My Carrier: Telus

Re: Can't Send Emails

Yes, that's exactly it. The message will appear in the sent box on the webmail client but never arrives at the destination. 

New Contributor
Posts: 7
Registered: ‎12-08-2011
My Device: Torch 9800 and Playbook
My Carrier: Rogers

Re: Can't Send Emails

The message was moved to sent folder when I checked, but never sent. Did not send to 10 dfferent email addresses (my other emails and friends email address). The problem was something with my hosting companies settings not working well with BB10. I switched my email hosting to Godaddy and it works now.
New Contributor
Posts: 6
Registered: ‎02-16-2013
My Device: Z10
My Carrier: Telus

Re: Can't Send Emails

Unfortunately the email host wasn't helpful so I have mail forwarding to a gmail account that works well from the phone. 

Contributor
Posts: 14
Registered: ‎03-23-2013
My Device: Z10
My Carrier: Vodafone

Re: Can't Send Emails

[ Edited ]

I'm having more or less this same problem.

 

I run my own email service, and have been using my BB 8510 with this for years now with no problems.

 

Have set up the BB Z10 with the same settings as the BB 8510, and am receving email correctly over IMAP/SSL.

 

However I cannot send email at all. New messages are going into the phones 'Outbox' folder with a grey clock icon, and never get delivered.

 

On the email server I can see that the phone successfully connects and the email server grants permission to relay, but after this point the phone just seems to disconnect without actually delivering the message.

 

I have tried both the Submit port on 587 and the regular SMTP port on 25, both with the same result. (note, we don't use the legacy port 465 on our email server)

Contributor
Posts: 11
Registered: ‎03-18-2013
My Device: Z 10
My Carrier: Etisalat

Re: Can't Send Emails