Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z10

Reply
Contributor
Posts: 49
Registered: ‎05-24-2013
My Device: Z10
My Carrier: Verizon

Contact Lookup Problem on Z10

When looking up a contact in the text message application, I have run into a problem.  I live in the South and a bunch of people I deal with have middle names.  I put the middle name into the middle name field in the contact application.  No problem there.  When I search for a contact (I have approximately 3,000, so there is no scrolling for me) in the contact application and start typing the name "Elizabeth S" the right contact comes up.  However when trying to send a text message and I type the same thing I get... NOTHING.  Turns out that Elizabeth has a middle name that start with G. So if I type "Elizabeth G" the right contact comes up.  The kicker is that "Elizabeth G" also works in the contact application, so why not for the text message application.

 

The work around has been for me to delete the middle / maiden names.  As a former programmer, it never seems good form to require your users to delete valid data to get the application to work properly.

 

Maybe this is fixed in 10.1, but unfortunately I'm on Verizon who is still running 10.0.  ;(

Forums Advisor III
Posts: 1,849
Registered: ‎05-29-2013
My Device: Passport & PlayBook
My Carrier: Bell

Re: Contact Lookup Problem on Z10

That seems weird, I don't see "Middle Name" field on my Z10, but when entering middle name I put it in the "First name" field and I have no problem finding my contracts currently the OS I'm running is 10.1 on Bell
_______________________________________________________
Want to contract me? You can follow me on Twitter @RobGambino
Highlighted
Contributor
Posts: 49
Registered: ‎05-24-2013
My Device: Z10
My Carrier: Verizon

Re: Contact Lookup Problem on Z10

Maybe that is part of the problem.  I have an Exchange Server that I'm using.  When creating a contact on the BB, I don't see a way to add a middle name.  But in Exchange it is a standard field.  So I created a test contact in BB and added the middle name in Exchange.  The middle name shows as a separate filed in BB Contact App!  But when searching its like the whole name is a single field.