Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z10

Reply
Contributor
Posts: 10
Registered: ‎09-18-2013
My Device: Z10
My Carrier: Vodafone

Continuing Frustration with Z10

Here's a last attempt to find solutions to the many problems I've encountered with my Z10 over the last 4 months. I am at the end of my tether and am about to chuck the thing in the dustbin. This is doubly frustrating as the actual phone part of the device is way better than the apple products I have migrated from. However the list of issues is so long I can't put up with them any more. In no particular order: 1. Email performance is erratic. Sometimes it works great but at other times and quite unpredictably it fails to connect with my email account and won't send or receive emails. It tells me I need to update my password. Sometimes when I do this it fixes itself, other times it doesn't. The net result is I cannot rely on the device to send or receive emails. 2. I cannot sync my Apple Address book or Calendar with the phone using the blackberry Link. I have spent HOURS trawling the net trying to find a solution but nothing works. Even had a professional IT guy look at it and he concluded that there must be a bug in the software. I am using the current version. 3. As a work around to problem 2 I set up an iCloud account and used that to get access to my Mac's address book. Unfortunately this suffers from problem 1 and I frequently (several times a day) get messages telling me that my iCloud account info is incorrect. When I re-enter my password it usually works for a few hours before giving me he same message! I can't get my Mac Calendar to sync at all via this route. 4. Wifi is temperamental. I can sometimes get a very slow connection with my home router but not always. All my family's Apple devices connect with 100% reliability and are much faster. I dare say that if I was a professional IT consultant I might be able to re-programme my device to somehow deal with these issues but as a mere lay person of average intelligence I am stuck with no one to turn to. I have wasted hours of my life trying to fix the ********* thing and am about to hit it very hard with a large inanimate object!! I hoped the new OS release 10.2 would address these issues but nothing seems to have changed for the better. Ironically my wife's older Blackberry running the OS 7 suffers from none of these issues. She uses the same ISP, wifi and Mac that I do. So I can only conclude that BB10 is to blame.
Forums Advisor II
Posts: 920
Registered: ‎04-01-2009
My Device: Z10 10.2.1.3247
My Carrier: T-Mo USA

Re: Continuing Frustration with Z10

[ Edited ]

OK. I'll start anyway. What OS are you running? What Router are you using?

I originally had the email issues you are describing back on 10.0 OS and only on my pop3 account. My 100% "fix" workaround was to install an app from BBerry world called K9. However, with update to 10.1 these issues have been fixed and I uninstalled K9. BUT... you might have a word with your provider? They can pooch your email.

Synch with Apple. I'm sure someone on this forum can help you as there are plenty who have switched from Apple. I'll bet they can best your IT guy...

Router issue. Again, what router? When I have had issues with any device I have changed channels, updated router firmware, done a simple reset on router. Does the phone connect to other routers?

At worse you could try a security wipe -- an easier try would be a hard reset: hold both volume keys down (ignore camera sound) until phone shuts down. Let us know, please.

Contributor
Posts: 10
Registered: ‎09-18-2013
My Device: Z10
My Carrier: Vodafone

Re: Continuing Frustration with Z10

Thanks for the constructive reply. I'm using OS 10.2. Re the email it works fine on my Mac, iPad, my wife's BB 9720, and my daughter's iPhone 5c. With that fact pattern won't my ISP just say it's a Z10 issue? Re sync with Apple, if someone can tell me what I'm doing wrong they will have a friend for life! I've reloaded the BB Link software several times and have the current version. When I press the sync calendar and contacts option is just doesn't do anything! Have had this problem from day one. My IT guy played with it for an hour and couldn't make it behave either - so I don't think it's something obvious. My router is made by Netgear. Will see if I can find a more specific description. My phone does work well with the router in my local Starbucks! Have tried the hard reset. Will let you know if that makes any difference. My overall point to Blackberry however is that this phone is not suitable for sale to the general public. When I bought my daughter her iPhone last month it took me 10 minutes to get it fully functional. It's been 100% reliable since. I've spent 4 months trying to get the Z10 to work and still haven't succeeded. It's really sad because the fundamental design is spot on, the phone part performs very well and the fact you can replace the battery a big plus. That's why I've persevered for so long!
Forums Advisor III
Posts: 1,177
Registered: ‎01-23-2009
My Device: Samsung Galaxy S2, Samsung Galaxy S3, Samsung Galaxy Note 4, BlackBerry Torch 9800, BlackBerry Z10, Blackberry Z30, BlackBerry Priv
My Carrier: Fido

Re: Continuing Frustration with Z10

Generally speaking , I had some small issues with my email connecting - all this, after and an update. My email accounts were still there after the new OS upload, allI had to do is enter passwords and click save. Well, it wasn`t that easy..... so I deleted ALL email accounts from my phone and re-booted the phone. Then I started adding back all the email accounts and I had no problems since.