Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z10

Reply
Highlighted
New Contributor
Posts: 2
Registered: ‎03-15-2012
My Device: Playbook 32GB
My Carrier: Rogers

Dropped Data Connection requires reboot

[ Edited ]

I own Z10 model STL100-3. OS is 10.2.0.1743. Radio is 10.2.0.1744. WLAN is 1.1.  I keep losing my data connection and have to reboot several times a day. The occurrences increase when I am traveling in the city vs working at the office or home.  I can normally see the data connection drop and get re-established. I can manually turn Data Services and/or Mobile Network off and on and it will re-establish the Data Services connection. But intermittently the Mobile Network drops to voice only. The WIFI will not connect as is just keeps searching and will not establish a connection to a know good source. When I pick my saved wifi it times out. The only resolution is to do a soft reboot. Have tried hard reboot, battery pull, security swipe, no SD card (using Kingston MicroSDXC 64GB). Then data and when available wifi connections are establish and fully functional until the next unrecoverable data connection drop.

 

This has been happening since MR1. I have been upgrading leaked OS in hopes to resolve the issue as I don't want to go backwards. I have done security wipe and not restored or installed any new apps. It has been to Fido for warranty repair with the claim it is 100% functional which is not the case. It failed the same day I picked it up from warranty service. I cannot tell from the service report what was replaced if anything. I have a new label to replace the one on the Z10 box and it has a different revision version so I assume some internal hardware was replaced.

 

I downloaded Blackberry Virtual Expert Powered by Asset Science Build 1.11.81. All the components pass the tests. I have gotten replacement SIM from Fido. I have called Fido from my place of work to examine signal strength but still no luck.  I have a second battery. I have cleaned the connections.

 

What else can I do to get my purchased Z10 fully functional? I am dependent receiving messages in a timely fashion but now I am having to constantly watch the data connectivity status on the top right of the screen.

 

I have had other BB phones no issue. There are several other Z10 at my place of work and they do not experience this issue. It is only me. We have had up to 4 various BB sm - 97xx and 99xx at home and none of them exhibit this data connection drop behavior.

 

Thanks in advance.

Trusted Contributor
Posts: 132
Registered: ‎06-22-2013
My Device: Z10 (STL 100-2) -10.1.0.4181
My Carrier: Optus

Re: Dropped Data Connection requires reboot

Hopefully the official 10.2 SW Version will have the correct radio files once it's passed by your carrier.
Disclaimer:
I know a little about lots of things,
yet not a great lot about those little-things.
Ultimately, I'm here to learn.
New Contributor
Posts: 2
Registered: ‎03-15-2012
My Device: Playbook 32GB
My Carrier: Rogers

Re: Dropped Data Connection requires reboot

I can replicate the issue by moving to a location in my house with no carrier signal or wi-fi. When I move back to carrier availability I have lost the data and cannot get back wi-fi. Turning off wi-fi or network carrier or data services and turning back on will not re-establish data services. I thought was wi-fi holding things up so I did same experiment with wi-fi off. Same results. The software appears to have given up attempts to gain back data services. I see many times sign drop, LTE or G down grade to lte or g. But then bounces right back. Big improvements from 10.0 and 10.1. I just want to make sure this bug gets noted and corrected. I love my BlackBerry and I am not giving it up. I'm looking forward to the Z30. Noted the improved antenna fixed battery so these must be 2 areas of concern. Better reception and no more battery pulls.

Thanks