Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z10

Reply
New Contributor
Posts: 2
Registered: ‎07-09-2013
My Device: Z10
My Carrier: vodafone

I can't pass the license agreement.

I can not get past the license agreement on Blackberry z10 Phone. Please help. My phone is connected to a wireless network but i can't get license agreement. I tried updating, restoring to factory settings but the same problem appears. It always sends me back to the previews image were i have to slide.

Super Contributor
Posts: 323
Registered: ‎05-10-2011
My Device: Z10

Re: I can't pass the license agreement.

When you say you are connected to a wireless network, do you mean the cellular data network or a WiFi network?

If you are on cellular data and cannot get the license agreement to load, it is likely that your data service is not setup correctly by your carrier and you cannot access the Internet as a result. Try connecting to a WiFi network if you can.

You must have an Internet connection to complete setup since the license agreement is downloaded during the setup process.
----------
BESX 5.0.4, SQL 2008, Exchange 2010 SP2 RU4a
Highlighted
New Contributor
Posts: 2
Registered: ‎07-09-2013
My Device: Z10
My Carrier: vodafone

Re: I can't pass the license agreement.

Thanks for the answer. When I mean an internet connection I Wifi connection. I will describe everything now. The first thing that has to  be told is that I am in an other country then in the one I have my cellular contract. So I am using roaming. The second issue is that roaming data does not work so I just use wifi network. So I booth the Z10. I started is and it asked me for a pin. I inserted the pin for my sim and then asked me to choose an internet connection. I choose the one I have at my office right now and then I wrote the password. Everything seemed to be fine and the Z 10 told me I am connected. He asked me to slide and immediately the following text appeared: "unable to connect to the network. Please try changing you're settings." Chose the one option I had: Settings. and I've been send again to the step it told me to slide.

I tried more open connections I found nearby but  the same problem appeared again. I tried and succeeded updating the Z10 with Blackberry link but the problem still remains. I do not now what to do.

Thanks again for help.