Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z10

Reply
Contributor
Posts: 18
Registered: ‎10-27-2011
My Device: Z10
My Carrier: Vodafone UK

Icons blank, can't delete

[ Edited ]

I too am having this problem with my Z10. They are not in my accounts but keep reappearing
on my apps screen a while after deleting. The icon is blank. Also the Vodafone sim app will not delete at all which is odd as my phone is sim free.

Hall of Famer III
Posts: 57,244
Registered: ‎11-28-2008
My Device: PRIV (6.0.1/AAF518), Z10/Z30/Q10 (10.3.2.2813), Playbook (2.1.0.1526)
My Carrier: TMobile USA

Re: Can't Delete FB app from Blackberry HUB!! New Z10

Hello,

 

Please, some clarifications...


TheNoseybonk wrote:
I too am having this problem with my Z10. They are not in my accounts but keep reappearing
on my apps screen a while after deleting.

You say "they"...this thread is discussing the FB app specifically, so I am not sure if your problem is truly identical, different, or similar. Please provide details to help us understand.


TheNoseybonk wrote:
The icon is blank.

Please also expand on that...a blank icon? If you can attach a screen image, that would also help.


TheNoseybonk wrote:
Also the Vodafone sim app will not delete at all which us odd as my phone is sim free.

While I've no idea what a "sim app" even is, you likely need to talk to Vodafone about that...it is completely possible that they push that to all of their customers, regardless of service plan.

Thanks and let us know!

 



Occam's Razor nearly always applies when troubleshooting technology issues!

New to the Community? Click here and also here for helpful guidance. Also please click here for additional helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions. If anyone has been helpful to you, please show your appreciation by clicking the button. Need a reference to BB10 OS/SR versions? Click here. Need a specific BB10 AutoLoader? Send me a private message.

...................................................... ......................................................
Contributor
Posts: 18
Registered: ‎10-27-2011
My Device: Z10
My Carrier: Vodafone UK

Re: Can't Delete FB app from Blackberry HUB!! New Z10

[ Edited ]

Please see screen shot below.. You can see that the apps I'd thought I'd deleted (inc FaceBook which I don't use and have never signed up for) have 'blank' icons as stated.. And the vodafone app (with a 'sim' icon) will not delete at all despite the small bin icon appearing when I press and hold it..  Perhaps this belongs on a different thread ??

 

 

 IMG_00000027.png

 

 

 

Hall of Famer III
Posts: 57,244
Registered: ‎11-28-2008
My Device: PRIV (6.0.1/AAF518), Z10/Z30/Q10 (10.3.2.2813), Playbook (2.1.0.1526)
My Carrier: TMobile USA

Re: Can't Delete FB app from Blackberry HUB!! New Z10

Since deleting the apps, have you rebooted?


Occam's Razor nearly always applies when troubleshooting technology issues!

New to the Community? Click here and also here for helpful guidance. Also please click here for additional helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions. If anyone has been helpful to you, please show your appreciation by clicking the button. Need a reference to BB10 OS/SR versions? Click here. Need a specific BB10 AutoLoader? Send me a private message.

...................................................... ......................................................
Contributor
Posts: 18
Registered: ‎10-27-2011
My Device: Z10
My Carrier: Vodafone UK

Re: Can't Delete FB app from Blackberry HUB!! New Z10

Hundreds of times - its when I reboot they 'reappear'
Developer
Posts: 6,473
Registered: ‎12-08-2010
My Device: PlayBook, Z10
My Carrier: none

Re: Can't Delete FB app from Blackberry HUB!! New Z10

This (the "blank icon" and screenshot thing) is reminiscent of a time when I managed to mess up the package id on a test app that I was installing in dev mode, so that it duplicated that of another app that was already installed.

The system didn't like that. I added this thread to cover it (though nothing in it will likely help here) http://supportforums.blackberry.com/t5/Testing-and-Deployment/Getting-quot-result-failure-502-unexpe...

As you can see from the last two posts there, things were really messed up. I didn't report it at the time, but one of the things I tried doing was deleting all the apps that I could delete... That *appeared* to work, but after a reboot the apps were mostly back, and at least several had "blank icons" the same as this.

It might be entirely unrelated, but with some similar symptoms, it may hint at a serious latent problem which I triggered by doing dumb things as a dev, but which can be triggered in other ways inadvertently by users.

(Sorry that's not really a help, though it's the start of a hint that you may have no choice but to wipe it. I wouldn't do that too quickly though, unless it's urgent and you have no other options left, including waiting for more ideas.)

Peter Hansen -- (BB10 and dev-related blog posts at http://peterhansen.ca.)
Author of White Noise and Battery Guru for BB10 and for PlayBook | Get more from your battery!
Guru II
Posts: 21,530
Registered: ‎04-01-2008
My Device: BlackBerry PRIV; BlackBerry Z30, Z10 and Q10 w/OS 10.3.2.2639; PlayBook w/OS 2.1.0.1917
My Carrier: AT&T

Re: Can't Delete FB app from Blackberry HUB!! New Z10

If it were me I'd reload the OS from scratch. Be sure and make a backup using Link first, though.

http://www.blackberry.com/btsc/KB33480

--------------------------------------------------------------------------------
1. Please thank those who help you by clicking the "Like" button at the bottom of the post that helped you.
2. If your issue has been solved, please resolve it by marking the post "Solution?" which solved it for you!
Developer
Posts: 6,473
Registered: ‎12-08-2010
My Device: PlayBook, Z10
My Carrier: none

Re: Can't Delete FB app from Blackberry HUB!! New Z10

Even with a backup, note the risk, however, that you'll have the problem basically come back with the restore.

I had to do only a partial restore as a result. I'd manually backed up all my media already, so that wasn't a problem, but I had to remove "Apps" from the restore, and do only Settings. That worked okay, as I recall, but attempting to restore apps brought the problem back in. It appears the issue was a corrupted record of the installed apps, and restoring them did not clear that up.

Peter Hansen -- (BB10 and dev-related blog posts at http://peterhansen.ca.)
Author of White Noise and Battery Guru for BB10 and for PlayBook | Get more from your battery!
Guru II
Posts: 21,530
Registered: ‎04-01-2008
My Device: BlackBerry PRIV; BlackBerry Z30, Z10 and Q10 w/OS 10.3.2.2639; PlayBook w/OS 2.1.0.1917
My Carrier: AT&T

Re: Can't Delete FB app from Blackberry HUB!! New Z10

Agreed. Make a full backup, just in case, but don't do a full restore. In fact, I didn't even suggest a restore.

A similar thing happened to me after doing a full restore. That's when I reloaded the OS and restored nothing. I'm sure one of these days I'm going to lose my Password Keeper because of the lack of selective restore features.

--------------------------------------------------------------------------------
1. Please thank those who help you by clicking the "Like" button at the bottom of the post that helped you.
2. If your issue has been solved, please resolve it by marking the post "Solution?" which solved it for you!
Guru I
Posts: 19,017
Registered: ‎07-29-2008
My Device: Passport, Playbook, 9320BES
My Carrier: Bouygues _ SFR

Re: Can't Delete FB app from Blackberry HUB!! New Z10

I had the issue yesterday, with an app that I wanted to install from the BBWorld but it failed for some reason (I think I lost the WiFi network momentarily)

After reinstalling the app from the BlackBerry World, the icon is back, and I can launch the app (and then I deleted it).



The search box on top-right of this page is your true friend, and the public Knowledge Base too: