Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z10

Reply
Contributor
Posts: 34
Registered: ‎09-06-2011
My Device: Priv on AT&T
My Carrier: AT&T

Re: Problem sending emails on SMTP Port 25 with Z10

I support your thoughts completely.  Further I am really getting frustrated at the support from my two service providers, Web.com and ATTGlobal.net.  Neither can say anythong other than "we don't support Blackberry." 

 

The bigger question is how do we get this brought to the exectuive level attention at Blackberry so the get it fixed and hopefullly make those internal changes necessary to prevent a recurance.

jgrobertson
Priv on AT&T
Formerly, Playbook, Z10 and Passport
Contributor
Posts: 34
Registered: ‎09-06-2011
My Device: Priv on AT&T
My Carrier: AT&T

Re: Problem sending emails on SMTP Port 25 with Z10

This is not restricted to port 25.  If is for every configuration my providers can receive.

jgrobertson
Priv on AT&T
Formerly, Playbook, Z10 and Passport
New Contributor
Posts: 9
Registered: ‎07-29-2008
My Device: Not Specified

Re: Problem sending emails on SMTP Port 25 with Z10

I called my carrier (t mobile) they handed the call to BlackBerry tech support, after few minutes the call was escalated to a high analyst, we ran few tests and I sent in a device report. Conclusion they are very well aware of the issue, that will be patched with 10.1 meanwhile solution is:

Change smtp server for that account or use K9.

And of course forget about att and go with another carrier Smiley Happy

Dino
Trusted Contributor
Posts: 210
Registered: ‎03-17-2013
My Device: Z-10
My Carrier: T-Mobile

Re: Problem sending emails on SMTP Port 25 with Z10

[ Edited ]

Correct -- the protocol problem is NOT port-specific.  It is a botch of the SMTP protocol itself in that body lines terminate only with a LF, not the proper CRLF pair.

 

This is definitely wrong on Blackberry's part, but a server should handle this even though it is technically improper.  Mine does although if it is running in "strict" mode it will log complaints about this behavior.

 

A server that refuses email that is malformed MUST do so with a 5xx response code; that is a permanent error and if it you get one, you must not retry the transmission.  If the server mangles the email or drops the connection unsolicited (or, for that matter, returns a temporary failure code for what is a hard error) it is also broken.  

 

That does not excuse Blackberry's broken code, but the fact remains that a server that causes such a client to indefinitely retry transmission or worse, accepts the email and then mangles it rather than delivering it, is broken far worse and is IMHO unfit for use on the Internet.

 

K9mail does not suffer from this as K9mail is completely independent.  That may or may not be acceptable to use in the interim.

 

Market Information? Come read The Market Ticker!
New Contributor
Posts: 4
Registered: ‎04-04-2013
My Device: Z10
My Carrier: ORANGE DOMINICANA

Re: Problem sending emails on SMTP Port 25 with Z10

Im also at WEB.COM .....and told me that they cant do anything because everything is running perfect on every platform also in OTHERS blackberry models, so definetely its a Blackberry 10 problem.....im using k9 so far its frustrating
New Contributor
Posts: 9
Registered: ‎07-29-2008
My Device: Not Specified

Re: Problem sending emails on SMTP Port 25 with Z10

Use a different SMTP
Super Contributor
Posts: 264
Registered: ‎05-24-2009
My Device: Z10
My Carrier: AT&T

Re: Problem sending emails on SMTP Port 25 with Z10


luismanuel26 wrote:
Im also at WEB.COM .....and told me that they cant do anything because everything is running perfect on every platform also in OTHERS blackberry models, so definetely its a Blackberry 10 problem.....im using k9 so far its frustrating

my provider also said every device is working fine and even other blackberry devices of which i still have.  but you call bb support and they blame it on the carrier, or tell you to switch carriers, or say others are out of date and z10 is using all the latest protocols. 

 

let's see.  z10 is superior yet other devices and old blackberrys are working just fine with the settings from my provider but the z10 fails to authenticate smtp with the same settings.  ok let's recap.  all other devices work except the z10.  now how in the heck is that supposed to be superior?  z10 is the problem.  fix the z10 **bleep** it! 

 

don't tell me to switch carriers or finagle around with settings until i hit one that z10 decides it wants to cooperate with and then blame my provider.  the world does not revolve around the z10!

 

admit that z10 has a problem and that a fix is in the works. 

 

oh but if we do that, people will return the z10 so let's just give them lame **bleep** workarounds so we don't look bad on gizmodo, cnet, and crackberry.  well you are looking bad to your loyal customers instead though!

New Contributor
Posts: 4
Registered: ‎04-03-2013
My Device: Z10
My Carrier: ATT

Re: Problem sending emails on SMTP Port 25 with Z10

THANK YOU BLACKBERRY!  Just downloaded the software update for the Z10 (10.0.10.116) and now my email works perfectly.  I really like the phone, especially the HUB.   All good. 

New Contributor
Posts: 4
Registered: ‎04-04-2013
My Device: Z10
My Carrier: ORANGE DOMINICANA

Re: Problem sending emails on SMTP Port 25 with Z10

That update seems to be for the STL 100-2 model and i have STL 100-1...hopefully we get that fix for us too ASAP. We still can NOT send emails. We are on WEB.COM

New Contributor
Posts: 9
Registered: ‎07-29-2008
My Device: Not Specified

Re: Problem sending emails on SMTP Port 25 with Z10

I'm on T-Mobile-US  no update here!

 

Dino