Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z10

Posts: 1
Registered: ‎06-14-2013
My Device: BlackBerry® Z10
My Carrier: Telus

Smart Dialing - Won't autmatically add "1" to 800,866,877 numbers


I've noticed an interesting issue with my  Z10, I didn't have this problem on any of the previous models.


Whenever I'm trying to call a toll-free number, it is not adding 1 in front of it when they are written as 10 digit numbers. For instance, my carrier is Telus, and their support phone number is 1-866-558-2273, which with the 1 in front of it dials perfectly fine. If I dial 866-558-2273, it gives me a carrier switch message that tells me the number is not in service.


However, if I dial other Canadian or American long distance numbers (Area codes 403, 613, 732, 281, etc..) I hear a message about long distance charges being applied and it would connect for me.


My wife has a Z10 also, however her carrier is Rogers, and I believe their switch auto-corrects this issue, because I can dial 10 digit 800, 866, or 877 numbers from her phone without issue.


I hoped the update to the new 10.1 might address this (currently running, however it acts the same.


I checked my Smart Dialing settings, and the Country Code (1 - Canada), Area Code (416), and National Number Length (10), are all see. I've tried altering those with different combinations, couldn't get anything to make a difference.


Doing a little searching, I came across a Verizon support page: http://support.verizonwireless.com/clc/devices/knowledge_base.html?id=75247


That talks about Smart Dialing, however there is one extra option on that screen that I don't see on my phone, "Select the "Use 1 for National Dialing" On/Off switch."


I have contacted a few colleagues who have Z10/Q10's on Telus also and they also have the same issue.


I opened a ticket with Telus, and they confirmed that their switching equipment doesn't automatically add a "1" in front of the numbers. 


I tried searching for this topic and came up with a lot of Smart Dialing topics, but nothing specifically to this sort of issue, apologies if it has been asked and answered elsewhere.


I'm hoping that there's something simple that I've missed to correct this issue, any ideas on what's happening here?