Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z10

Reply
Highlighted
New Contributor
Posts: 3
Registered: ‎06-27-2014
My Device: Z10
My Carrier: Telus
Accepted Solution

Switching Devices

I have a new Blackberry Z10, and I want to transfer all of the data/apps etc from my old Z10.  The problem is when I try and switch them via Blackberry link it says the OSs are incomplatible.

 

The OS on my old device is SR- 10.2.1.2941 OS - 10.2.1.3175 and on my new device SR - 10.2.1.2102  OS - 10.2.1.2141.

 

I've tried updating the software on both devices through Blackberry link and both say the device has the latest version of the software.

I've tried doing a backup on the old device and restoring it on the new device.

 

I would appreciate it if anyone has any suggestions, as to how I can get the devices switched.

Forums Advisor II
Posts: 983
Registered: ‎08-31-2013
My Device: BlackBerry Classic- SQC-100-4
My Carrier: T-Mobile USA

Re: Switching Devices

I would try re-installing BlackBerry link. Let me know if that helps.


 

1. If a post has helped you, show your appreciation by clicking Like at the bottom of the message box.
2. If a post has solved your question, please click ''accept as solution'' to verify your question has been solved.
Trusted Contributor
Posts: 166
Registered: ‎03-07-2014
My Device: Z10 STL100-2
My Carrier: Out

Re: Switching Devices

[ Edited ]

Hi,

 

You can't restore on lower OS backup made on higher version, so You should to use autoloader to upgrade lower OS, look here .

You'll get clean device in the end, and You'll can to restore backup of Your previous device. 

Elite II
Posts: 8,981
Registered: ‎01-05-2009
My Device: BlackBerry PRIV
My Carrier: Rogers

Re: Switching Devices

@Problem_child , your link doesn't work. Try this one:

 

http://supportforums.blackberry.com/t5/BlackBerry-10-OS-Device-Software/Upgrading-OS10-devices-using... 

 

 

Cheers.  Smiley Happy


- If my response has helped you, please click "Options" beside my post and mark it as solved. Clicking the "thumbs up" icon near the bottom of my response would also be appreciated.



New Contributor
Posts: 3
Registered: ‎06-27-2014
My Device: Z10
My Carrier: Telus

Re: Switching Devices

Before I started, I got the latest version of Blackberry Link 1.2.3.48

Guru II
Posts: 22,043
Registered: ‎04-01-2008
My Device: BlackBerry PRIV; BlackBerry Z30, Z10 and Q10 w/OS 10.3.2.2639; PlayBook w/OS 2.1.0.1917
My Carrier: AT&T

Re: Switching Devices

OS 10.2.1.3175 is no longer available for the Z10. You'll want to use the instructions in the Link BillJ posted and instead of the codes in that post, use the codes from the post below to install 10.2.1.3247. I will assume you have a STL100-2, or -3 and you can use the codes for either the -2, or -3.

http://forums.crackberry.com/bb10-leaked-beta-os-f395/sachesi-codes-os-downloads-920390/

--------------------------------------------------------------------------------
1. Please thank those who help you by clicking the "Like" button at the bottom of the post that helped you.
2. If your issue has been solved, please resolve it by marking the post "Solution?" which solved it for you!
Trusted Contributor
Posts: 166
Registered: ‎03-07-2014
My Device: Z10 STL100-2
My Carrier: Out

Re: Switching Devices


BillJ wrote:

@Problem_child , your link doesn't work. Try this one:

 

http://supportforums.blackberry.com/t5/BlackBerry-10-OS-Device-Software/Upgrading-OS10-devices-using... 

 

 

Cheers.  Smiley Happy


Oh, thanks BillJ, got it Smiley Happy

New Contributor
Posts: 3
Registered: ‎06-27-2014
My Device: Z10
My Carrier: Telus

Re: Switching Devices

This did it. Thanks to everyone who offered help.