Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z10

Reply
New Member
Posts: 2
Registered: ‎12-23-2013
My Device: BB Z10
My Carrier: BITE LV

The SIM card is from an unknown source

Hi!

My phone say this:

 

The SIM card is from an unknown source

 

I don't no what to do... Can any body can help?

 

 

and merry Christmas Smiley Wink

Forums Advisor II
Posts: 920
Registered: ‎04-01-2009
My Device: Z10 10.2.1.3247
My Carrier: T-Mo USA

Re: The SIM card is from an unknown source

And Merry Christmas to you! Is this a Verizon phone by any chance? And, despite the message, are you still getting service?
New Member
Posts: 2
Registered: ‎12-23-2013
My Device: BB Z10
My Carrier: BITE LV

Re: The SIM card is from an unknown source

Hi!

Tnx for respond!

I think it`s not a Verizon Phone, and all services are  working, (all BB services, wifi)

when I switch power on, phone are no zone, then i go to settings, mobile network.

and there is mobile network switched off, when i switch it ON, they says "The SIM Card is from an unknown source"

And that's all Smiley Sad

 

Do you understand what I want to say?

Forums Advisor II
Posts: 920
Registered: ‎04-01-2009
My Device: Z10 10.2.1.3247
My Carrier: T-Mo USA

Re: The SIM card is from an unknown source

Hi Marckello,

OK, I mean are all DATA services and all CALLING services working?

1) Are you sure your APN settings are set correctly for BITE LV? Go to Settings > Mobile Network > APV (at bottom) and check. BITE LV will have the correct info.

2) What model; phone do you have? Go to Settings > about > General > Model Number. What does it say?

3) What OS are you running? Go to Settings > about > OS . OS Version. What number?

4) When you switch your networks ON, do you get ALL service or just that message?

5) Are you sure your phone is UNLOCKED?

Thanks
Contributor
Posts: 40
Registered: ‎02-13-2014
My Device: Z10
My Carrier: Movistar Argentina

Re: The SIM card is from an unknown source

hi! I have the same problem several days ago and I can not solve, I know you will be able to help me. I have a Z10 100-1 STL Movistar Argentina, worked perfectly but suddenly no telephony service. no signal meter, instead there is a big red X and below it says "Unknown error". does not operate the radio, it does not allow or turn or off. change the SIM card, clear the device about 20 times and updated all OS versions I found on the web and still not working. Install the files separately radio testing different versions but does not work. updates made ​​from the phone, from BBLINK with autoloaders etc, but the radio still does not work. But even without the SIM card the radio NO WORK , so I think the problem is the radio. One thing: before this problem When I turned on/off my phone appeared logo Movistar (my carrier), but after this error anymore. and the radio setup menu I get the message "The SIM card is from an unknown source" although this is not the SIM inserted I receive this message. all BB services work perfect on WIFI, but I have no telephony service. only one big "X" red on place the signal meter. it may be this error? and how I can fix it? many thank you very much!
Forums Advisor III
Posts: 1,177
Registered: ‎01-23-2009
My Device: Samsung Galaxy S2, Samsung Galaxy S3, Samsung Galaxy Note 4, BlackBerry Torch 9800, BlackBerry Z10, Blackberry Z30, BlackBerry Priv
My Carrier: Fido

Re: The SIM card is from an unknown source


Marbrk wrote:
hi! I have the same problem several days ago and I can not solve, I know you will be able to help me. I have a Z10 100-1 STL Movistar Argentina, worked perfectly but suddenly no telephony service. no signal meter, instead there is a big red X and below it says "Unknown error". does not operate the radio, it does not allow or turn or off. change the SIM card, clear the device about 20 times and updated all OS versions I found on the web and still not working. Install the files separately radio testing different versions but does not work. updates made from the phone, from BBLINK with autoloaders etc, but the radio still does not work. But even without the SIM card the radio NO WORK , so I think the problem is the radio. One thing: before this problem When I turned on/off my phone appeared logo Movistar (my carrier), but after this error anymore. and the radio setup menu I get the message "The SIM card is from an unknown source" although this is not the SIM inserted I receive this message. all BB services work perfect on WIFI, but I have no telephony service. only one big "X" red on place the signal meter. it may be this error? and how I can fix it? many thank you very much!

Hello,

 

Did you get the phone from your carrier? Is the phone unlocked or still locked to your carrier?

Contributor
Posts: 40
Registered: ‎02-13-2014
My Device: Z10
My Carrier: Movistar Argentina

Re: The SIM card is from an unknown source

hi!, i buy the phone in Movistar Argentina. the phone is blocked from Movistar Argentina. i use an SIM card for Movistar.
Forums Advisor II
Posts: 920
Registered: ‎04-01-2009
My Device: Z10 10.2.1.3247
My Carrier: T-Mo USA

Re: The SIM card is from an unknown source

Are you sure your APN settings are correct?
Contributor
Posts: 40
Registered: ‎02-13-2014
My Device: Z10
My Carrier: Movistar Argentina

Re: The SIM card is from an unknown source

I'm sure it is not to set APN in the Z10, but if you tell me where it is I will. thanks!
Contributor
Posts: 40
Registered: ‎02-13-2014
My Device: Z10
My Carrier: Movistar Argentina

Re: The SIM card is from an unknown source

Well, here I am again. I installed the 10.2.1.2102 and still gives me the same error message and have no telephony services. I'm lost. any idea? thanks!