Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z10

Reply
New Contributor
Posts: 3
Registered: ‎02-12-2013
My Device: Blackberry Z10
My Carrier: O2

Unable to add email accounts to Z10

Got new Z10 to day, upgraded from Torch, and have spent 4.5 hours on the phone with mobile provider techie (O2) and web host IT person going around in circles. I am now at my wits' end! I have just googled 'Unable to set up email accounts on BB Z10' and see that numerous people are having this issue.

 

Can we get help from BB techies on here??

 

I am trying to set up two (private ) email accounts on the Z10 and what seems to be happening is that the phone cannot communicate with my web host provider's server. I managed to set up a TalkTalk account no problem (different ports) but it won't work with the private email accounts.

 

Judging from the various posts I've read, this seems to be a BB issue. I desperately need to resolve this as I am running my own business.

 

HELP!

Highlighted
Forums Advisor I
Posts: 568
Registered: ‎02-05-2013
My Device: Blackberry Z10, Blackberry Playbook 64gb
My Carrier: Bell

Re: Unable to add email accounts to Z10

I also ran into this when I picked up my phone last Tuesday. I have a private web site for my business and private email accounts that run on their server. When I tried to setup the pop account it would't set it up. The cause of the problem is that the SMTP servers are being blocked by your service provider for your phone( read this KB29891) . The only way around for me  was to use another SMTP server( I used my cable modem server smtp.broadband.rogers.com) for your outbound email. Later on I got the guy hosting my mail server to change the smtp server from port 25 to port 26 and that also worked.

New Contributor
Posts: 3
Registered: ‎02-12-2013
My Device: Blackberry Z10
My Carrier: O2

Re: Unable to add email accounts to Z10

Thank you! It's pretty much what my web host techie suggested.
Contributor
Posts: 10
Registered: ‎02-18-2013
My Device: z10

Re: Unable to add email accounts to Z10

Help! I use a number of pop email accounts for work and am having no joy setting them up on my z10. Had the 8900 for years and found it very reliable. 

 

I like the z10 phone and want to stick with it but with the issue of not syncing with outlook and not being able to set up email accounts I am on the verge of returning the phone and moving to the samsung or Iphone.  I am talking with my service providor at the moment but they are struggling to provide a solution. Does a simple solution exist for a non techie person like me can use?

Hall of Famer III
Posts: 57,550
Registered: ‎11-28-2008
My Device: PRIV (6.0.1/AAG111), Z10/Z30/Q10 (10.3.2.2813), Playbook (2.1.0.1526)
My Carrier: TMobile USA

Re: Unable to add email accounts to Z10


mpzt wrote:

Help! I use a number of pop email accounts for work and am having no joy setting them up on my z10. Had the 8900 for years and found it very reliable. 

 

I like the z10 phone and want to stick with it but with the issue of not syncing with outlook and not being able to set up email accounts I am on the verge of returning the phone and moving to the samsung or Iphone.  I am talking with my service providor at the moment but they are struggling to provide a solution. Does a simple solution exist for a non techie person like me can use?


Hello,

 

Actually, setting up accounts is usually simple, requiring only the email address and password, then the wizard takes over. But, if your email server cannot provide back to the device the required parameters, you must then use the advanced settings and provide the parameters directly.

 

But, from your description, I cannot at all tell what is exactly happening for you..."no joy" isn't really much to go on...if you provide us some details (e.g., the exact steps you try, the exact results of each step, along with the exact and complete content of any error messages presented), then we might be able to give you some helpful advice.

 

Thanks and let us know!



Occam's Razor nearly always applies when troubleshooting technology issues!

New to the Community? Click here and also here for helpful guidance. Also please click here for additional helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions. If anyone has been helpful to you, please show your appreciation by clicking the button. Need a reference to BB10 OS/SR versions? Click here. Need a specific BB10 AutoLoader? Send me a private message.

...................................................... ......................................................
Contributor
Posts: 10
Registered: ‎02-18-2013
My Device: z10

Re: Unable to add email accounts to Z10

Thanks Sd. Yes I thougt it would be easy, the set up on my old Blackberry was quick and easy. Technical support think it is to do with my contract plan. I purchased in store and support say my plan hasn't been updated on the system and therefore won't give me emails. Seems strange as my bold 8900 was fine for years on the old contract. I will try the store this morning and see if that resolves the situation. 

New Contributor
Posts: 3
Registered: ‎02-12-2013
My Device: Blackberry Z10
My Carrier: O2

Re: Unable to add email accounts to Z10

With me, in the end, it turned out to be a 'bolt' (whatever that is) that had to be removed from my old BB 9800 set up by my mobile provider, it was blocking me setting up emails on the Z10.
Hall of Famer III
Posts: 57,550
Registered: ‎11-28-2008
My Device: PRIV (6.0.1/AAG111), Z10/Z30/Q10 (10.3.2.2813), Playbook (2.1.0.1526)
My Carrier: TMobile USA

Re: Unable to add email accounts to Z10


mpzt wrote:

Thanks Sd. Yes I thougt it would be easy, the set up on my old Blackberry was quick and easy. Technical support think it is to do with my contract plan. I purchased in store and support say my plan hasn't been updated on the system and therefore won't give me emails. Seems strange as my bold 8900 was fine for years on the old contract. I will try the store this morning and see if that resolves the situation. 


That may well be the cause. BB10 devices no longer use BIS...rather, they use ActiveSync directly on the device to inteface, via the generic data pathway, with email services. But, it is odd to me...if you have generic data services, it would be odd to me for BIS to be needed or in the way. But, anyway, do talk to them to work this out.

 

Good luck!



Occam's Razor nearly always applies when troubleshooting technology issues!

New to the Community? Click here and also here for helpful guidance. Also please click here for additional helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions. If anyone has been helpful to you, please show your appreciation by clicking the button. Need a reference to BB10 OS/SR versions? Click here. Need a specific BB10 AutoLoader? Send me a private message.

...................................................... ......................................................
Hall of Famer III
Posts: 57,550
Registered: ‎11-28-2008
My Device: PRIV (6.0.1/AAG111), Z10/Z30/Q10 (10.3.2.2813), Playbook (2.1.0.1526)
My Carrier: TMobile USA

Re: Unable to add email accounts to Z10


MMB13 wrote:
With me, in the end, it turned out to be a 'bolt' (whatever that is) that had to be removed from my old BB 9800 set up by my mobile provider, it was blocking me setting up emails on the Z10.

Hello,

 

Prior to BB10, many carriers called their BB-specific data plans (which were required to activate BIS, which included a variety of BB-specific services, including email) a "BlackBerry Bolt-On". It is surprising to me that the existence of the bolt-on prevented you from configuring email on your device, but I suppose that they may have been routing data traffic differently with the Bolt-On, and perhaps preventing ActiveSync from working.

 

For you specifically, after they removed the Bolt-On, does your BBM continue to work? This is a subtle point about which I've been trying to obtain confirmation, so your reply would be most appreciated.

 

Thanks and good luck!



Occam's Razor nearly always applies when troubleshooting technology issues!

New to the Community? Click here and also here for helpful guidance. Also please click here for additional helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions. If anyone has been helpful to you, please show your appreciation by clicking the button. Need a reference to BB10 OS/SR versions? Click here. Need a specific BB10 AutoLoader? Send me a private message.

...................................................... ......................................................
New Contributor
Posts: 6
Registered: ‎03-03-2013
My Device: Z10
My Carrier: Telus

Re: Unable to add email accounts to Z10

Hello:

 

I just had the same issue, and called my carrier (Telus) and was able to get support to fix it.  It turns out that the Z10, being in a 4GL network, when setting up a new POP account, it requires the use of the SMTP server of the carrier, as opposed to the SMTP server of the e-mail service.  As soon as I changed the SMTP server to SMTP.telus.net it started working.

 

With my old Blackberry Bold, being on a 3GL network, this was not an issue, and I used to be able to use the SMTP server of my e-mail service.

 

I hope it helps,