Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z10

New Contributor
Posts: 6
Registered: ‎04-02-2013
My Device: Z10
My Carrier: Airtel

Unable to connect to my office laptop

For the past few days, when connecting my Z10 to my office Laptop I keep getting an error message "USB device not recognized". 


It was working perfectly for the past 4-5 months and my USB ports are enabled.  They can't seem to figure out why it isn't connecting and the phone doesn't charge as well.

Posts: 16
Registered: ‎09-19-2012
My Device: Z10
My Carrier: Rogers

Re: Unable to connect to my office laptop

Hey mark_dcosta,

Thanks for the question.

Have you tried testing with the other USB ports on the laptop? If so, try running through the steps listed here. Also, if available, try using a different USB cable.

Let me know how you make out with this.



Come follow your BlackBerry Technical Team on Twitter! @BlackBerryHelp

Be sure to click Like! for those who have helped you.

Click Accept as Solution for posts that have solved your issue(s)!

Forums Advisor III
Posts: 1,395
Registered: ‎02-28-2009
My Device: Torch, Bold, Play Book, and Bluetooth HS-700
My Carrier: BELL

Re: Unable to connect to my office laptop

I have seen a number of things cause the Link software, and other types of backup programs for various devices fail for a number of reasons.  Running a software firewall such as the Windows Firewall, or a virus scanner firewall can cause this type of problem. If you are accessing the net with a good quality router, or modem, most have a built in hardware firewall that is very effective. A second firewall should not be required. Software firewall programs generally slow the system down, and have been known to cause conflicts with many types of port access devices.


If turning off the computer firewall software does not fix the fault, or if you are not running a firewall software try the instructions below.


  • Connect the phone to the USB port.
  • Go to Device Manager. (Control Panel, System, Device Manager)
  • Find Ports (COM & LPT), and open this area.
  • Remove the RIM vertual port entries.
  • Disconnect the phone.
  • Restart the computer.
  • Start the Link program. 
  • When the Link program starts log out and log back in to the Blackberry ID account for your phone.
  • Re-connect the phone.

The operating system should re-install the device drivers for the phone.



If the above does not work:


  • Start the Link program.
  • Log out of your Blackberry ID account for your phone.
  • Remove the RIM vertual port entries in the Device Manager (see above).
  • Uninstall the Link program.
  • Restart the computer.
  • Re-install the Link program.
  • Log in to your Blackberry ID account for your phone.
  • Connect the phone to the USB port.
  • Allow the drivers to re-install for your phone.


If all of the above still does not work the problem can be more complicated. It would be best to get in touch with Blackberry support.




Jerry G.