Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z10

Reply
Highlighted
Contributor
Posts: 23
Registered: ‎02-17-2013
My Device: Z10
My Carrier: Bell

WIFI connection problems

Hi

 

I have problems staying connected to my WIFI network with the Z10. The Z10 right away detects my local WIFI network and connects. There is a strong signal showing in the top right corner of the screen. Launching the browser, I can load one or two pages then it stops and after a while I get a message that I am not connected to the internet.

The only way to get a connection back is to turn off and on the WIFI signal in the Z10.

Then again I have a connection, the browser loads one or two pages then stops again,no connection. Same error message. I have been through that vicious circle about 10 time now.

 

To try to solve the problem I changed the WIFI connection from Auto IP (DHCP) to a manual fixed IP, same results, the Z10 connects then disconnects even tough it still shows a strong connection signal in the screen and shows "connected" when pulling down the menu from the top of the screen and also in settings.

 

This is NOT a local network problem as I have and iPad (WIFI) , PC (direct connection to the router) and desktop Mac (WIFI) all staying connected perfectly. 

 

To finish, the Z10 is running the original OS 10.0.9.2372. It has not been updated yet

 

Any Ideas on how to fix it?

 

Fizou

 

 

Retired
Posts: 3,198
Registered: ‎01-27-2010
My Device: BlackBerry Z10

Re: WIFI connection problems

Hi fizou,

 

Have you checked to see if the update is available from your provider? If so, try applying the update then connect to your Wi-Fi network again.

 

Thanks.

 

-CptS

 

Come follow your BlackBerry Technical Team on twitter! @BlackBerryHelp

Be sure to click Kudos! for those who have helped you.

Click Solution? for posts that have solved your issue(s)!

Contributor
Posts: 23
Registered: ‎02-17-2013
My Device: Z10
My Carrier: Bell

Re: WIFI connection problems

Hi
No update yet, i am with Bell, Smiley Sad

Fizou
Forums Advisor III
Posts: 1,423
Registered: ‎02-28-2009
My Device: Torch, Bold, Play Book, and Bluetooth HS-700
My Carrier: BELL

Re: WIFI connection problems

[ Edited ]

I have had this problem with tablets and phones. When I had this problem I noticed that there were other WiFi networks nearby that had very strong signals. For some reason the phone was trying to switch over and access the other networks.

 

On the Z10, I don't see the feature for the WiFi to only show and work with saved connections. The tablet has that feature.

 

A fix may be to try setting up your WiFi source (router) to a different format. For example if it is in automatic change it to manual and try g or b type. You can also see if there is the option to change the channel group. I realize this starts to become complicated for the average person to start experimenting with.

 

If the WiFi source is set to a different standard, you may have to re-register the phone to your new WiFi spec if it does nto find it on its own. 

 

 

 

 

Jerry G.
New Member
Posts: 1
Registered: ‎03-04-2013
My Device: Z10
My Carrier: Rogers

Re: WIFI connection problems

There seems to be a correlation between the problem and the manufacturer of the router, in my case d-link.

New Contributor
Posts: 8
Registered: ‎03-04-2013
My Device: Z10
My Carrier: airtel

Re: WIFI connection problems

I'm facing the same problem. The phone connects to the wifi network, is connected to internet for first few seconds and then it breaks. It doesnt download anything after that. It I turn off the Wifi from my phone and switch it on, it's same thing again. I'm using the same internet network on my computer and facing no problems there, so the wifi is working fine. My software release is 10.0.10.58 and it's showing no updates available yet.

If anyone finds a solution please do share, this is a very annoying error and needs an update asap..

New Member
Posts: 3
Registered: ‎03-06-2013
My Device: Blackberry z10
My Carrier: Orange CH

Re: WIFI connection problems

Hey I have the exact same problem... Wifi stays connected for like 1-2 minutes and after that it doesnt work anymore. If I reconnect, I have the exact same problem again. I have updated already . It worked fine before updating. And every other device connects fine to my wifi. I already reset my blackberry z10 twice and it doesnt work. Please help me.
Contributor
Posts: 23
Registered: ‎02-17-2013
My Device: Z10
My Carrier: Bell

Re: WIFI connection problems

Hi
It could be the Dlink router. I have one at my studio where I have thé problem. But I have no problem at home where I am using an apple express router.
It is not the phone or the OS
Contributor
Posts: 23
Registered: ‎02-17-2013
My Device: Z10
My Carrier: Bell

Re: WIFI connection problems

I mean it is not the phone OS problem
Guru III
Posts: 32,199
Registered: ‎06-25-2008
My Device:

I'm rockin the BlackBerry DTEK60, Passport, Z30, Z10, Q10, BlackBerry Mini Stereo Speaker, 64 gig PlayBook,BT Headset HS-700

My Carrier: I am on AT&T. Please edit your Personal Profile with your DEVICE TYPE, DEVICE OS and Carrier

Re: WIFI connection problems

Look at my tips on wifi

Speed-up-BlackBerry-Wi-Fi-connections-a-knottyrope-tip

 

 




Click here to Backup the data on your BlackBerry Device! It's important, and FREE!


Click "Accept as Solution" if your problem is solved. To give thanks, click thumbs up
Click to search the Knowledge Base at BTSC and click to Read The Fabulous Manuals

BESAdmin's, please make a signature with your BES environment info.


SIM Free BlackBerry Unlocking FAQ
Follow me on Twitter @knottyrope


Want to thank me? Buy my KnottyRope App here


BES 12 and BES 5.0.4 with Exchange 2010 and SQL 2012 Hyper V