Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z10

Reply
New Contributor
Posts: 5
Registered: ‎05-11-2013
My Device: Blackberry Z10
My Carrier: Vodacom

Wifi Proxy Problems

Hi,

 

Since I updated to BB OS 10.1, my phone has issues with my work wifi. I have had 10.1.0.1448 and am now on 10.1.0.1720, both have thee same issues. My work wifi has a http/https proxy. Previously my phone would only use the proxy for these protocols, while still allowing account syncing protocols to go direct. Since the new OS update, all protocols get pushed to the proxy if I add it in my phones settings. So I can either browse the web (with proxy settings enabled) or have my accounts sync (with my proxy settings disabled). Very annoying, can you please make the proxy settings more flexibile, allowing the protocols to be selected that must go via the proxy.

Highlighted
New Contributor
Posts: 5
Registered: ‎05-11-2013
My Device: Blackberry Z10
My Carrier: Vodacom

Re: Wifi Proxy Problems

[ Edited ]

Hi,

 

Just a slight bit of behaviour that might help.

When I connect to the wifi, initially my accounts (gmail etc.) will sync for up to 2 hours. Then my account will show as not connected in the accounts section of the settings.

 

So I am thinking, maybe the Z10 does a address lookup on my 3g succesfullly, and only when it refreshes the lookup does it fail because of the proxy.

 

When I go into my account settings and select connect, it will give a 'server no response error'.

 

If I then go into my wifi profile, remove the proxy setting from the wifi profile, then the account will connect and retrieve my mail/contact/calender updates. But then my browsing is dead.

 

Hope this helps, because I dont know how to fix it.

The 10.0 OS worked perfectly, my colleagues android/apple phones have no problem, soo doubt it is the wifi.

 

Regards

Werner