Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z10

Reply
Highlighted
New Member
Posts: 1
Registered: ‎09-18-2013
My Device: Blackbery Z10
My Carrier: Bell

Wifi auto-connection issues

[ Edited ]

Hello,

I recently purchased a Blackberry Z10 and am very happy with it, however there seems to be a bug with my wifi. Whenever I'm at home and select my home wifi it connects and works perfectly fine, however, every day when I leave for work my wifi list is still populated by my home networks, and it still shows my wifi as being connected even when I'm miles out of range of my router. It doesn't show the actual wifi networks near me until I turn on and off my wifi. After I do that, it automatically connects to my saved networks like it should, however, it has the same problem everywhere I go. It only shows the wifi networks of the last place I turned my wifi on and off, even if I'm nowhere near those networks.

 

This is becoming really annoying and I can't fix it no matter which settings I change. I'm worried I'm going to rack up a massive phone bill from data usage because I tend to use my phone data when I should be connected to wifi, but apparently it hasn't been autmatically connecting to wifi like it should.

 

Any help would be appreciated.

 

Version: 10.1.0.4181

Retired
Posts: 134
Registered: ‎05-16-2013
My Device: Q10/9900/9790
My Carrier: Rogers

Re: Wifi auto-connection issues

Hello kyle100

Welcome to the BlackBerry Support Community Forums.

 

The BlackBerry Z10 smartphone should disconnect from the local Wifi Network once you have become out of range. If you have connected to a Wifi Network and saved it the BlackBerry Z10 smartphone should connect right away. If the Wifi Network settings have not changed there normally should be no issue connecting once you enter the Wifi Network signal range.

 

How long has the BlackBerry Z10 smartphone be experiencing this issue?

 

The next steps I would take in order to help resolve the issue you are having are to reload the BlackBerry Z10 smartphone device software. Once the reload is complete I would then recommend testing the issue without restoring data. The issue could be related to the current configuration and data on the BlackBerry Z10 smartphone.

*Note before reloading the BlackBerry Z10 smartphone software please backup the data stored on the BlackBerry Z10 smartphone using BlackBerry Link.

BlackBerry Link can be downloaded and installed from the below site:

www.blackberry.com/blackberrylink

To backup the BlackBerry Z10 smartphone Software please follow the below steps:

Windows/Mac

1.On your computer, open BlackBerry Link.
2.Connect your device to your computer using a USB cable.
3.At the bottom of the screen, click your device.
4.Click the Settings icon. In the Settings view, in the left pane, click Back Up Now.

Note: You can select data to include in your backup files by selecting specific data in the Settings view.

Alternatively, the following steps can also be performed:

1.To back up your device data, you can also click beside your device at the bottom of your screen. Click Back Up.

To reload the BlackBerry Z10 smartphone software please follow the below steps:

1.Open BlackBerry Link.
2.Connect the smartphone using the micro USB cable.
3.At the bottom of the BlackBerry Link window, click the Computer tab.
4.Select settings.
5.Under Reload Device Software, select Reload.
6.Follow the on-screen instructions.

Once the BlackBerry Z10 smartphone smartphone has been reloaded please attempt to test to see if the issue can be reproduced.

I look forward to your reply


Goose947


 


Come follow your BlackBerry Technical Team on Twitter! @BlackBerryHelp


Be sure to click Like! for those who have helped you.

Click Accept as Solution for posts that have solved your issue(s)!


New Contributor
Posts: 7
Registered: ‎10-03-2013
My Device: Blackberry Z10
My Carrier: Vodafone

Re: Wifi auto-connection issues

I am now on my second blackberry Z10 because of wifi issues and this one is the same. I have no data on this one yet. When setting up it updated itself to the latest software. It connected easily and quickly to my office wifi. Last night though it took hours before it recognised my home wifi. Once connected, then it was fast. When I move to any other wifi, it is slow to find them. When I came to the office this morning, it does not connect automatically to my office wifi that I saved yesterday. I have to click on it.
New Member
Posts: 1
Registered: ‎03-23-2014
My Device: Z10
My Carrier: Fido

Re: Wifi auto-connection issues

hi there,

 

I am having exactly the same issue from so long.

 

I have paid large data bills in the last couple of months due to this problem.

 

Any help in this matter will be appreciated !!

 

Thanks,

Forums Veteran I
Posts: 1,877
Registered: ‎12-23-2013
My Device: Z30, Z10
My Carrier: Vodacom

Re: Wifi auto-connection issues


kyle100 wrote:

Hello,

I recently purchased a Blackberry Z10 and am very happy with it, however there seems to be a bug with my wifi. Whenever I'm at home and select my home wifi it connects and works perfectly fine, however, every day when I leave for work my wifi list is still populated by my home networks, and it still shows my wifi as being connected even when I'm miles out of range of my router. It doesn't show the actual wifi networks near me until I turn on and off my wifi. After I do that, it automatically connects to my saved networks like it should, however, it has the same problem everywhere I go. It only shows the wifi networks of the last place I turned my wifi on and off, even if I'm nowhere near those networks.

 

This is becoming really annoying and I can't fix it no matter which settings I change. I'm worried I'm going to rack up a massive phone bill from data usage because I tend to use my phone data when I should be connected to wifi, but apparently it hasn't been autmatically connecting to wifi like it should.

 

Any help would be appreciated.

 

Version: 10.1.0.4181


Update to OS 10.2.1.2141, radio Version 10.2.1.2142 will be installed.

Your radio version should be 10.1.0.4182, could also be your problem if it's a higher number.