Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z10

Reply
Regular Visitor
Posts: 1
Registered: ‎04-09-2013
My Device: Z10 9700
My Carrier: NA

Windows 7 64bit driver

Amazing, I can not connect my Z10 to my PC. 

Windows find "RIM Network Device" but can't find a driver for it !!!

 

 

The software on the Z10 called "Device Manager" is not working. 

To solve it I installed Blackberry Link. 

But this is no good for development.

I am using Eclipse Plugin to transfer Android apps to Blackberry, but when I use "Auto Detect" to connect to the device, it never finds it. Please Help.

 

Where can I find a proper "USB driver" for Windows7-64 ?

How to get a working version of "Device Manager"?

 

 

I need a solution ASAP !!

 

Thanks in advance

 

Trusted Contributor
Posts: 232
Registered: ‎11-19-2010
My Device: Z10, Playbook

Re: Windows 7 64bit driver

Device manager does not (and will not) support OS10 devices. Link is used for OS10.

 

It sounds like your problem is with Eclipse, not the Z10.

 

I use Link under Windows 7 64-bit just fine. The internal flash and SD flash card also appear as mounted devices.

 

There are other ways to side-load android apps. Some quick searches should find them for you.

Highlighted
New Contributor
Posts: 8
Registered: ‎04-08-2013
My Device: Z10
My Carrier: NA

Re: Windows 7 64bit driver

Same problem using computer with  Windows 7 32bit, packging with Command Line tool. LINK found the device, packaging worked fine until trying to "blackberry-deploy -installDebugToken ...".

Got: 

[Fatal Error] :1:1: Premature end of file.
Error: Authentication failed due to system error

 

My device information from Settings-->About--> General:

Model: Anonymous

Model Number:  STL100-3

OS Version: 10.0.8.111

 

Real Device with new microSD memory card. no SIM (it's for devlopment use only)

 

Please assist.

 

Thanks in advance