Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z10

Reply
Contributor
Posts: 16
Registered: ‎01-31-2013
My Device: BlackBerry Z10
My Carrier: O2

Z10 IMAP Folder Settings

Hi

 

My IMAP server uses Sent Messages as the location for... well, sent messages.  Deleted messages are stored in the folder 'Deleted Messages'.  There is no where I can see on the Z10 to define these folders.  Email being sent is being saved in a new folder called 'Sent'.  As a result threading isn't working for all of the messages I've previously sent.

 

Thanks

Contributor
Posts: 15
Registered: ‎03-23-2013
My Device: Z10
My Carrier: Vodafone

Re: Z10 IMAP Folder Settings

Similarly, our deleted messages box is called 'Trash'. We also have a separate 'Spam' folder which the mailserver scans to update its spam filtering, so being able to 'file' messages into this IMAP folder is vital.

 

Currently I cannot see the Trash or Spam folders on my BBz10, but could interact with them just fine on the BB Curve 8510 which I've just upgraded from.

 

Looks like another piece of BB functionality lost. Am questioning why I went with the next gen BB now rather than Android.

New Contributor
Posts: 3
Registered: ‎05-15-2013
My Device: Z10
My Carrier: Verizon

Re: Z10 IMAP Folder Settings

Ditto here, only with a popular service: gmail. Its regarding the Spam folder. I have confirmed its setup as IMAP, within gmail website under Labels I have Spam 'Show in IMAP' & show in folder list both highlighted. I have tried to go to 'Edit Folder Settings' on phone (Z10 under Edit Account), but got message 'Unable to find folders for this account'. Indeed I have not added any folders/labels, just the default ones gmail came with. I have restarted the phone multiple times & keep hitting refresh under the Hub settings, nothing will help

 

OS v10.0.9.422

Contributor
Posts: 15
Registered: ‎03-23-2013
My Device: Z10
My Carrier: Vodafone

Re: Z10 IMAP Folder Settings

Suggest that you update the software on your phone - 10.0.9.422 is quite out of date. Mine is currently on 10.0.10.690.

New Contributor
Posts: 3
Registered: ‎05-15-2013
My Device: Z10
My Carrier: Verizon

Re: Z10 IMAP Folder Settings

I tried directly from phone & it said it was already up-to-date. I then tried on WiFi again, same. Restarted, no help. When I get my hands on the phone again (business here) I will be updating from a PC
Highlighted
New Contributor
Posts: 3
Registered: ‎05-15-2013
My Device: Z10
My Carrier: Verizon

Re: Z10 IMAP Folder Settings

I actually called RIM & the tech told me gmail must be blocking it based on error I got from going to Edit Folder Settings. I told him I did make a custom label via gmails website & prior to me calling I had gone into Edit Folder Settings & it went-through without error, but only gave me a checkbox for my custom label, nothing else (if I remember correctly), thus I thought the label might be messing it up, so I deleted it on gmail's website & ever since got that error. His other suggestions were: update phone SW, then try edit folder settings again, then try removing & re-adding account, then try different ports (he gave me site www.blackberry.com/eavt2 to help with that, I found kb33444 for help on the site). If that still fails he suggested trying pop