Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z10

Reply
New Contributor
Posts: 7
Registered: ‎03-23-2013
My Device: Blackberry Z10
My Carrier: Etisalat

Z10 automatically deleting emails

[ Edited ]

I am using Blackberry Z10 with Activesync of Microsoft Exchange Server 2010. Everything was working fine for 30 days.  

 

But now I noticed that some of the emails are getting deleted automatically from the device. When I checked the emails in Outlook I could find the emails in 'Deleted Items'. Some of them are permenantly deleted and could recover only from 'Recover Deleted Items' of Outlook. 

 

I am sure that I didnt delete the emails nor I have any autoarchive set in the Outlook.

 

I am intrested to know if anybody else face the same issue.

 

 

Hall of Famer III
Posts: 58,165
Registered: ‎11-28-2008
My Device: DTEK50 (AAH108), PRIV (AAH995), Z10/Z30/Q10 (10.3.2.2813), Playbook (2.1.0.1917)
My Carrier: TMobile USA

Re: Z10 automatically deleting emails

Hello,

Given what you describe, you appear to be on BES...as such, you should work with your BES admins to diagnose this issue.

Good luck!

Occam's Razor nearly always applies when troubleshooting technology issues!

New to the Community? Click here and also here for helpful guidance. Also please click here for additional helpful information to guide you as you proceed. I always recommend that you treat your BlackBerry like any other computing device, including using a regular backup schedule...click here for an article with instructions. If anyone has been helpful to you, please show your appreciation by clicking the button. Need a reference to BB10 OS/SR versions? Click here. Need a specific BB10 AutoLoader? Send me a private message.

...................................................... ......................................................
New Contributor
Posts: 7
Registered: ‎03-23-2013
My Device: Blackberry Z10
My Carrier: Etisalat

Re: Z10 automatically deleting emails

Thank you for your reply.

I am using activesync not BES

Highlighted
New Contributor
Posts: 3
Registered: ‎04-10-2013
My Device: Blackberry Z10
My Carrier: T-Mobile

Re: Z10 automatically deleting emails

I am having this exact issue. Did you find an answer?

New Contributor
Posts: 7
Registered: ‎03-23-2013
My Device: Blackberry Z10
My Carrier: Etisalat

Re: Z10 automatically deleting emails

Its not there anymore, it was only that week. Two things I did was, Take out the battery and put it back without turning of the device. Second thing, I changed the password of the email account.

 

Good luk for you.

New Contributor
Posts: 5
Registered: ‎04-12-2013
My Device: Blackberry Z10
My Carrier: Rogers

Re: Z10 automatically deleting emails

I seem to be having this issue as well execpt my email is not deleted in Outlook, it just dissapears off my phone if I don`t immediately reply and I cannot recover it anywhere on the phone..pissed off and don`t understand this..
New Contributor
Posts: 7
Registered: ‎03-23-2013
My Device: Blackberry Z10
My Carrier: Etisalat

Re: Z10 automatically deleting emails

The problems still exists, interesting the emails are getting deleted as a batch, say 15 emails get deleted at once. Dont know how it get deleted for you guys.

Visitor
Posts: 1
Registered: ‎04-15-2013
My Device: Z10
My Carrier: Telus

Re: Z10 automatically deleting emails

I'm having a similar issue with email deleting off my Z10, I understand what's happening, but can't find settings to resolve it.

 

I have multiple email accounts, all of which i check using outlook on my desktop, but i also like to get copies to my phone. The issue is that if outlook checks first and retrieves an email, it deletes it off the server and my phone never gets a copy. If i set outlook to leave a copy on the server, both outlook and my Z10 receive copies (that's good!), except my storage on the server now starts to grow. I've tried setting outlook to leave a copy on the server for 2 days, plenty long enough for copies to get to both outlook and my z10, but as soon as that time lapses, the email is removed from the server and is deleted off my z10. Bottom line, i don't want my phone "syncing" with the server, i just want it to retrieve email and keep it on the phone regardless of what happens in either outlook or on the server, which is how my torch worked previously and i never had an issue.

New Contributor
Posts: 7
Registered: ‎03-23-2013
My Device: Blackberry Z10
My Carrier: Etisalat

Re: Z10 automatically deleting emails

Hi Shawnstill,

 

I think that you are using a pop account, not exchange server activesync. In you case if you set to leave a copy it should be fine. But in my case it syncs with exchange mailbox and cannot find it anywhere.

 

Blackberry has removed the BES express option from Z10, which is really a probelm with me.

 

Forums Advisor III
Posts: 1,036
Registered: ‎02-07-2013
My Device: Z10
My Carrier: Rogers

Re: Z10 automatically deleting emails


nisarbari wrote:

Hi Shawnstill,

 

I think that you are using a pop account, not exchange server activesync. In you case if you set to leave a copy it should be fine. But in my case it syncs with exchange mailbox and cannot find it anywhere.

 

Blackberry has removed the BES express option from Z10, which is really a probelm with me.

 


You can now run a single user license of BES10 if you need to, they changed the licensing so that it is affordable for small business that already have an exchange server. It isn't free, but it is affordable.

 

If your email is disappearing from the z10 after 30 days, then it is likely that you are simply seeing the 30 day sync period max that is currently hard coded into the z10. This is supposed to be changing in the 10.1.X update according to some posts I have read elsewhere.

 

 

-: DrewRead :-
Can't find an app on Blackberry World yet? Tweet the developer and ask when they will #GetWithBB10 !!
"Like it" if you like it. Smiley Happy