Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z10

Reply
Contributor
Posts: 33
Registered: ‎09-16-2013
My Device: Z10

Z10 battery issue (HOT battery)

Okay, so this morning I received a notice to update BB World app. So I did. Then checked my Twitter account, and closed it. Received another notification to update my at&t app. So I did.
When I checked my phone again about 10 minutes later, the back was "HOT" and the battery (after being charged overnight) had gone down to 20% from 100%.
This is the 4th time my phone has done this. Pressing down and holding the power button for 30 seconds is the only cure I've found thus far. Then of course, I have to recharge the phone.
Any help in resolving this issue is welcomed and appreciated.
Carrier is at&t. Model is Z10 STL 100-3, software release is 10.1.0.2019 and OS is 10.1.0.2074
Thanks again!

Trusted Contributor
Posts: 131
Registered: ‎03-26-2013
My Device: Z10
My Carrier: AT&T

Re: Z10 battery issue

My battery (or back) is not hot, nor did I notice it as such last night.  However, last night I also received an update notice for BlackBerry World and allowed the update.  I placed in on charger overnight exactly as I have done since March.  Unless I happen to really use it a lot, my battery makes it all day from 7 am to 11 pm just fine.  It is now 10:30 am and my battery is less than 50%!

 

WTF?

Trusted Contributor
Posts: 131
Registered: ‎03-26-2013
My Device: Z10
My Carrier: AT&T

Re: Z10 battery issue

I should add this: since I took the phone off the charger this morning, I have made exactly zero phone calls.  I opened and responded to one email.  The only thing I have used on my phone is the Tune In Radio app.  I listened to ESPN radio on the drive into my office this morning for about 20 minutes.  I do this every day, and on some days when I travel, I may listen to Tune In for a couple hours, with no battery issues.  I opened and closed the app the same way I always do, and other than those things, my Z10 has simply been sitting on my desk.

 

When I made my first post, my battery was right at 50% after 3.5 hours.  In the few minutes since the previous post, it now sits at 45%.

 

Bluetooth is off, nfc off, wifi is off. My office is in a good mobile area with good LTE signal.  I have not watched videos, the phone is not searching for signal.  Other than the update for BB World, my phone is exactly the same as it was yesterday.