Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z10

Reply
New Contributor
Posts: 3
Registered: ‎05-06-2013
My Device: z10
My Carrier: rogers

Re: Z10 encoding issue in outgoing email

Yeah, why is that you have to literally go under a truck to make z10 work with everything else. This phone is a joke!

Visitor
Posts: 1
Registered: ‎05-03-2013
My Device: Z10
My Carrier: Tmobile

Re: Z10 encoding issue in outgoing email

I had to return that piece of **bleep**  Z10 after long hours of trying with tmobile and BB technical dept.  After both companies blaming each other. For 30 consecutive days Noone at tmobile were able to make the Z10 to send emails on a simple POP3 account.

 

I had to go back to my bold and all my problems went away, now I get instant email instead of 15 minutes waiting period. I have been with BB for 10years, and now I see the ending of a once a functional and pretty straight forward email base phone company. Whoever decided to change the strength of the company to this new piece of **bleep** email service need to be fire ASAP.

 

Good bye BB and your unless platform

Highlighted
Trusted Contributor
Posts: 210
Registered: ‎03-17-2013
My Device: Z-10
My Carrier: T-Mobile

Re: Z10 encoding issue in outgoing email

You don't. My Z-10 ran against my IMAP and SMTP servers from the first day without a single problem. Then again, my server is implemented against the premise that one is liberal in what one accepts and yet strict against standards in what one emits.

There are a lot of coders of various server software out there who do not play by those rules. Certainly BB should not have bugs in their code, but all code has bugs. Therefore as a software developer I can either code defensively or not, but if I choose "not" I must suffer the consequences when I want that code to talk to other people.

Incidentally the debugging check that logs this particular mistake shows that about 5% of the GLOBAL email connections I receive are similarly in error. If your email provider cannot handle them YOU ARE SILENTLY MISSING EMAILS FROM PEOPLE WHO YOU MIGHT WANT TO TALK TO! Anyone who is running into this problem with THEIR email provider IS MISSING EMAILS from people -- that is, YOUR provider is screwing you silently. I guarantee it. The Z-10 exposed to you what was being done to your correspondents without your knowledge.

That is why I code defensively, because I want my code to interoperate even against less-than-perfect implementations.
Market Information? Come read The Market Ticker!
New Member
Posts: 3
Registered: ‎08-08-2012
My Device: Playbook, Bold9700
My Carrier: Bell

Re: Z10 encoding issue in outgoing email

Good Solution!  I should have drwan the same conclusion from computer client settings concerning the smtp.