Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z10

Reply
Highlighted
New Contributor
Posts: 5
Registered: ‎10-24-2013
My Device: BlackBerry Z10
My Carrier: Rogers

Z10 keeps disconnecting from home wifi network

I just switched from a Samsung Galaxy to a BlackBerry Z10 a couple of days ago and I am having trouble with my home wifi. The Galaxy never had issues with it and stayed on constantly but the Z10 connects for a few minutes and then disconnects again and won't re-connect unless I reboot the router. I made sure I had the latest firmware on the router and updated the Z10 software as well. Apparently there is some setting on my wifi that was ok for the Galaxy but not ok for the Z10 and I hope someone can help me figure it out. Nothing else is using the wifi and the signal strength is very good.

 

What happens:

 

The phone connects successfully to the wifi. I open the browser and go through a few pages and then suddenly a page won't load at all. Sometimes the phone says it is still connected to the wifi and sometimes it sends me a message saying that the network has limited access to some websites. Sometimes it will instead switch to 4G. It doesn't only happen when I use the browser. Sometimes I am not using anything on it at all but just look at it and see it has switched to 4G.

 

I go into the settings and I see that it says my wifi network is disabled. I enable it again and confirm all the settings are fine and try to connect. Sometimes it goes through three attempts and then gives up. Sometimes it only tries once and gives me a message that it is unable to authenticate against the network and that I should verify network security settings and try again. No matter how many times I try, it does not connect until I log in to my router and reboot that. Then it connects immediately without my having to do anything.

 

So I am pretty sure this means a problem with my router settings.

 

I am using WPA/WPA2 - Personal security and confirmed that setting and the password on the Z10 are correct.

 

On the Z10, "Auto Obtain IP" is on.

 

I always have trouble with network stuff and it means little to me so, if anyone knows what is going on, please don't give me technical jargon! If you need more info, I will provide.

 

Thanks! I don't want to have to take it back but if it won't work for me, I might have to get another Samsung instead.

New Contributor
Posts: 5
Registered: ‎10-24-2013
My Device: BlackBerry Z10
My Carrier: Rogers

Re: Z10 keeps disconnecting from home wifi network

An update, in case anyone else is experiencing anything similar ...

 

After troubleshooting with various technicians at various companies, it appears the problem was actually a faulty router. I don't understand why my Samsung had no issues with it (or my laptop) but when I replaced it with another router I had kicking around, the BlackBerry had no problem connecting and it has been about three hours so far without disconnecting at all.

 

I suppose I'll come back here if the problem recurs but, in the meantime it appears to be just one of those weird things. So I guess the moral is to try everything, even if you don't think it could possibly be the cause, because you just never know.

New Contributor
Posts: 7
Registered: ‎10-25-2013
My Device: Z10
My Carrier: Vodafone Italy

Re: Z10 keeps disconnecting from home wifi network

Have you set your router to work as Wireless GN ?

 

Could you please try to set BG wireless?

 

My access point is the netgear wn604 that it can't manage the pure N connection but only GN.

 

After different test i suppose that the Z10 must be used in a Pure N Wireless Connection.

 

 

 

 

New Member
Posts: 1
Registered: ‎04-28-2014
My Device: Blackberry z10
My Carrier: blackberry

Re: Z10 keeps disconnecting from home wifi network

hello sir, i too have the same problem with my blackberry z10. At first it used to connect to my office wifi but now it doesnt connect at all. Can you suggest me anything...?
New Member
Posts: 1
Registered: ‎01-10-2016
My Device: Blackberry Q10
My Carrier: Kyivstar

Re: Z10 keeps disconnecting from home wifi network

[ Edited ]

i has the same problem with my q10 ("connects for a few minutes and then disconnects again and won't re-connect unless I reboot the router")

 

and right decision is change setting of my wifi router (tp-link) from 11bgn to 11n only

 

great thanks, ltm82!

 

upd.: 11n worked few hours, but after that began the same story with dicinnects and reboots, i change regime of router to 11g, and now all my devices work without any problems.

Forums Veteran I
Posts: 1,861
Registered: ‎12-23-2013
My Device: Z30, Z10
My Carrier: Vodacom

Re: Z10 keeps disconnecting from home wifi network

Try setting channel to Manual and use the same number, if no change then try another number.