Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z10

Posts: 1
Registered: ‎04-11-2013
My Device: Z10
My Carrier: Telus

Z10 on EAS Remote Search not performing.

Hello there!


I have a Z10 that is connecting to our Exchange Server via EAS.


Because of the 30 day limitation on emails we are wanting to use the Remote Search function in order to retrieve older emails from the server. However, it only seems to retrieve result that are ~45 days old.


There don't appear to be any configuration issues with the phone and there are no configuration issues with the server as our iPhone and Android clients can retrieve emails of any age via an EAS connection.


My clients require the ability to search for older emails on the server; up to 3 years worth.


According to Blackberries official statement on searching for emails older than 30 days: http://www.blackberry.com/btsc/KB33742




Attempt a remote search to retrieve older emails. "


Well Blackberry, we have, and it doesn't.


Is this problem being worked on?




Guru III
Posts: 32,226
Registered: ‎06-25-2008
My Device:

I'm rockin the BlackBerry DTEK60, Passport, Z30, Z10, Q10, BlackBerry Mini Stereo Speaker, 64 gig PlayBook,BT Headset HS-700

My Carrier: I am on AT&T. Please edit your Personal Profile with your DEVICE TYPE, DEVICE OS and Carrier

Re: Z10 on EAS Remote Search not performing.

it is being looked into from what I have heard and it does not work on BES 10 either for me


Click here to Backup the data on your BlackBerry Device! It's important, and FREE!

Click "Accept as Solution" if your problem is solved. To give thanks, click thumbs up
Click to search the Knowledge Base at BTSC and click to Read The Fabulous Manuals

BESAdmin's, please make a signature with your BES environment info.

SIM Free BlackBerry Unlocking FAQ
Follow me on Twitter @knottyrope

Want to thank me? Buy my KnottyRope App here

BES 12 and BES 5.0.4 with Exchange 2010 and SQL 2012 Hyper V

Regular Contributor
Posts: 65
Registered: ‎06-07-2011
My Device: Playbook
My Carrier: Verizon

Re: Z10 on EAS Remote Search not performing.

Does anyone know whether this has been resolved in OS10.2?

BlackBerry Employee
Posts: 750
Registered: ‎05-15-2008
My Device: Z10
My Carrier: Rogers

Re: Z10 on EAS Remote Search not performing.

I'll dig up a KB article for this later but there is currently a known issue where remote searches are getting a 60 day filter applied.