Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z10

Posts: 20
Registered: ‎05-16-2013
My Device: Blackberry Z10
My Carrier: Vodafone

Re: sms problem after installing,please help

Thanks everyone. Will reinstall tonight.
New Contributor
Posts: 8
Registered: ‎05-16-2013
My Device: z10
My Carrier: zein

Re: sms problem after installing,please help

I think better to wait instead to face the all problems.
New Contributor
Posts: 3
Registered: ‎09-14-2011
My Device: Bold(abandoned by BB), Playbook (abandoned by BB), Z10 (mailer unusable), Google Galaxy Nexus
My Carrier: Speakout(Canada), Roam Mobile (US), Virgin Mobile (UK)

Re: sms problem after installing, POSSIBLE FIX AND REALLY AN INSTALLER BUG

The variety of "reinstall solved this problem" led me to try going into "Settings->Software Update" and trying to see if there was a quick fix - instead, it offered me to install a new update - again!!!!!


Either BB fixed it overnight AND lied about the build number (unlikely from what I know of their process) OR - more likely -


This is a bug that makes the installer fail to complete, not a bug in the SMS app at all!


So, if you are hit by this bug, please CLOSE AND RESTART SETTINGS, then try "Settings->SOftware Updates", "Check for UPdates" and if it offers you AGAIN, go for it, and watch to make sure it completes normally. (AFAIK the only way you can tell is to close and restart settings and do the "Check for Updates" again - looking at Settings->General>Software Release is not conclusive; mine said before this "second update" and still does.


So: no need to backup and security wipe, just go back to settings and re-do the update.


At least for me; your mileage may vary, but if it does, please report that here!

Java SE/EE/Android developer also doing BlackBerry development.
Posts: 26
Registered: ‎02-02-2013
My Device: Z10
My Carrier: Bouygues Telecom

Re: sms problem after installing, POSSIBLE FIX AND REALLY AN INSTALLER BUG