Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

BlackBerry® Z30

Reply
Highlighted
New Member
Posts: 1
Registered: ‎07-31-2014
My Device: z30
My Carrier: Pelephone

z30 not boot: no screen, not led lights, nothing...

Hi,
I can't believe this is happening to me. it's mt 4th blackberry, but something like that never happened before.
I have z30 for a year now.
today, after finished a phone call and starting a new phone call, the phone calls app stop responding. so I decided to restart my phone.
I did a restart (with the menus) and the blackberry stuch on the white blackberry logo. I tried a several times, with charger without charger, I pressed a 5 seconds on the power menu to get it restart over and over and the same result.
after the red light the blackberry white logo appeared on the screen and that's it. I waited an hour, but it's just stuck there.
I didn't install any new apps lately.
so I connected the blackberry to the pc and try with the blackberry link software to do a manufactor reset.
it's failed right at the beginning. It's look like when the red light appear it connected to the pc and when the blackberry logo appear it's disconnected from the pc.
so I thought to make an os upgrade. I just don't care anymore about my data, just to get the phone work again.
so I downloaded a new os version from here and it start ok. detect the blackberry, start to load the image and the about 30% it says "failed to load image" and that's it.
the blackberry now dont even start. no lights when pressing the button, tried to reinstall the os upgrade, nothing....
is my blackberry z30 is dead?
can I do something to fix it? buy a new motherboard or something?

thanks for your help...