Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Community Feedback and Ideas

Reply
Developer
Posts: 2,462
Registered: ‎11-04-2010
My Device: Bold 9700

Forum Graphics

Hey Guys,

 

Long time user -- I've noticed since the redesign (about a year ago or so) the site "buttons" have been off. Like the entire site uses a specific font but the button themselves (Cancel, Post, New Message, etc..) use Times New Roman font. Just seems inconsistent and gives the site a bad feel. A suggestion is to maybe go and change the font to be consistent with the other fonts on the website like the headers. Other than that the site is running great. Keep up the great work! Smiley Happy

J. Rab (Blog) (Twitter)
--
1. If you liked my post or found it useful please click on the thumbs up and provide a Like!
2. If my post solved your problem please click on the Accept as Solution button. Much appreciated!

Approved Apps: OnTrack | ssShots | Hangman
Guru I
Posts: 19,020
Registered: ‎07-29-2008
My Device: Passport, Playbook, 9320BES
My Carrier: Bouygues _ SFR

Re: Forum Graphics

GHA I understood, at last.

 

so, as you may know, the forum is based on a Lithium infrastructure (check in the bottom right corner of this page).

 

among other customizations, appearance depends on CSS files. in the file named :

http://rim.i.lithium.com/skins/HEAD/301ABB4987C330D237F4D2FCDC933761/rim-1991929921.css

 

on line 8563 there is a CSS declaration which says :

#lia-body .lia-content a.lia-button.lia-button-secondary,
	#lia-body .lia-content span.lia-button.lia-button-secondary,
	#lia-body .lia-content button.lia-button.lia-button-secondary,
	#lia-body .lia-content input.lia-button.lia-button-secondary
		{background:transparent url(/skins/images/E74F6CFD10A76191BD342058156F9535/rim-439108329/images/secondary_button_right.png) no-repeat scroll 100% 0; border:none;
		  color: #EEEEEE; font-family: lucida sans; font-weight: bold; height:31px; padding:0px 11px 0 0;  }

 It is interesting because the buttons are reached by the lia-button stuff.

 

the interesting part here is the font-family property, which is set to the value "lucida sans".

 

Unfortunately, "lucida sans" is not a font-family property, it is a font name (which is not present on my Windows 7 installation so I suspect it is present on the PC of the person who created the CSS file, but that person should be sticking to common fonts, or use a specific CSS rule to make the browser install the required fonts (I don't like that much, but this is allowed by CSS3).

 

Your browser probably defaults the font-family to the regular value "serif", and upon display the serif font is probably set to Times New Roman on your installation, and on mine it is "Georgia" (because of its funny way of displaying numbers).

 

*****

 

what is a pity, is that in the same CSS file, is another declaration that sets the Font-Family to Arial, which is the font-family that matches the rest of this website.




The search box on top-right of this page is your true friend, and the public Knowledge Base too:
Developer
Posts: 2,462
Registered: ‎11-04-2010
My Device: Bold 9700

Re: Forum Graphics

Hey Xandrex,

 

Ahh yes -- just decided to do some digging myself -- using chrome went into the font-family setting and yeah it's set to Lucida Sans. Unfortunately that font does not exist on Macs by default -- hence it resorts to the default Times. Indeed a more common font should be used in it's place like Arial.

J. Rab (Blog) (Twitter)
--
1. If you liked my post or found it useful please click on the thumbs up and provide a Like!
2. If my post solved your problem please click on the Accept as Solution button. Much appreciated!

Approved Apps: OnTrack | ssShots | Hangman