Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Downloaded Applications

Reply
New Member
Posts: 3
Registered: ‎05-26-2013
My Device: Q10
My Carrier: Vodacom SA

Applications for BB Q10

I have a problem whereby I am unable to install application for the BlackBerry Q10. It tells me the application not available for this device.

 

I the info for the application is states that it is suitable for Blackberry 10 OS.

 

Are the Z10 and Q10 not both OS 10

 

The Z10 is listed but not yet the Q 10, but if both are OS 10 it should not matter

 

Anybody know of these errors or how to overcome them

 

Thanks

Developer
Posts: 1,185
Registered: ‎03-24-2011
My Device: Passport/Z30//Q10/ Z10 / 9900 / PlayBook / 9700 / 8900
My Carrier: ATT

Re: Applications for BB Q10

Update OS.
This happen before when people couldn't download the whatsapp because they needed a certain OS release to be able to run it.

Try updating your OS.
Highlighted
New Member
Posts: 3
Registered: ‎05-26-2013
My Device: Q10
My Carrier: Vodacom SA

Re: Applications for BB Q10

Hi Teaboy

 

This is not on WhatsApp. That installed fine. I have a banking app that worked on OS 7 and after upgrading to tge Q10 it does not want to run

 

On the bank site it states that the application supports BB OS 10 and Z 10 but on the Q10 it does not want to install, not available for this device.

 

Same goes for applications like Mr Numberblocker, Call Blocker etc

 

Tells me not available for the device (Q10)

 

My OS has been upgraded to latest release and phone restarted.