Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Contributor
Posts: 18
Registered: ‎01-21-2011
My Device: BB7 - BB10
My Carrier: Developer

9860 blank map in Blackberry Maps and RichMapField

On 9860 we can't see the maps, both in Blackberry maps and in RichMapField. Everything above the map is visible (markers, zoom and pan controls, ...), but the map tiles aren't loading and we see a blank (full white) map.

We tested our app on these phones: 9790, 9810, 9220, 9900, 9380, 9320, 9860. Maps are working fine in all phones, except the 9860 (firmware: v7.1.0.694, Platform 5.1.0.507).

 

Blackberry Maps application was pre-installed in all "working" phones. In 9860 it is installed but the icon is not visible. To find it we have to d oan extended search.

 

We thought the cause of the problem could be the BIS disabled on SIM card, or Maps application not installed on phone. We now have ruled out these possible causes, testing the application in different environments:
* 9900 on wifi, maps installed: OK
* 9900 on GPRS (BIS enabled), maps installed: OK
* 9900 on wifi, maps installed: OK
* 9900 on GPRS (BIS enabled), maps uninstalled: OK
* 9380 on wifi, maps installed: OK
* 9380 on GPRS (BIS disabled), maps installed: OK
* 9380 on wifi, maps uninstalled: OK
* 9380 on GPRS (BIS disabled), maps uninstalled: OK
* 9860 on wifi, maps uninstalled: KO
* 9860 on GPRS (BIS disabled), maps uninstalled: KO
* 9860 on wifi, maps installed: KO
* 9860 on GPRS (BIS disabled), maps installed: KO

 

Could someone please provide us a fix?

 

Thanks in advance