Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Contributor
Posts: 6
Registered: ‎11-04-2010
My Device: BlackBerry® Bold™ 9000 BlackBerry® Bold™ 9700
My Carrier: DoCoMo

A Message "Invalid folder", when I try to install BlackBerry Java Plugin for Eclipse on Mac.

I got the BlackBerry Java Plugin for Eclipse on Mac installer for Mac from the link below.

http://us.blackberry.com/developers/javaappdev/macosx.jsp

 

And I tried to install it to Mac.

But the installation display the message "Invalid folder" and stops when I choose the installation directory.

I wanna complete the installation.

 

My mac spec is below..

OSversion:Mac OS X 10.5.8

 

New Developer
Posts: 8
Registered: ‎08-03-2009
My Device: Not Specified

Re: A Message "Invalid folder", when I try to install BlackBerry Java Plugin for Eclipse on Mac.

[ Edited ]

Same here. There are some explicit path constraints but my path seems compliant. Are we the only two who have seen this or are there others?

Highlighted
New Developer
Posts: 8
Registered: ‎08-03-2009
My Device: Not Specified

Re: A Message "Invalid folder", when I try to install BlackBerry Java Plugin for Eclipse on Mac.

I managed to install this on a different Mac. The only significant difference was that I used Eclipse 3.5.x as opposed to 3.6.x. But then I installed the older eclipse on the original Mac and it still didn't work. So I don't know what magical combination of elements makes the cryptic error message go away. What I do know is that this is par for the course with BlackBerry development. On Android, stuff just works, and it doesn't matter what version of Eclipse, what platform, what the path is--it's all good. What I also can't fathom is how RIM expects to win over the hearts and minds of potential developers when this is what they have to offer.

New Contributor
Posts: 6
Registered: ‎11-04-2010
My Device: BlackBerry® Bold™ 9000 BlackBerry® Bold™ 9700
My Carrier: DoCoMo

Re: A Message "Invalid folder", when I try to install BlackBerry Java Plugin for Eclipse on Mac.

Thanks for your answer.

The problem was Mac OS X's version not about path.

I overlooked the sentence "Mac OS X's version is 10.6 or above." wrriten on the installation guide.

I update the version 10.5 to 10.6 and I done the installation on Mac succesfully.

thanks.

 

New Contributor
Posts: 6
Registered: ‎11-04-2010
My Device: BlackBerry® Bold™ 9000 BlackBerry® Bold™ 9700
My Carrier: DoCoMo

Re: A Message "Invalid folder", when I try to install BlackBerry Java Plugin for Eclipse on Mac.

thanks Sparkletron.

I updated the version 10.5 to 10.6 and I've done the installation on Mac succesfully.

 

>What I do know is that this is par for the course with BlackBerry development.

I got that's why the forum exists.

 

thanks a lot.

New Developer
Posts: 8
Registered: ‎08-03-2009
My Device: Not Specified

Re: A Message "Invalid folder", when I try to install BlackBerry Java Plugin for Eclipse on Mac.

This revelation corresponds with my scenario; I have one Mac running 10.5.x, another running 10.6.x. The former doesn't work; the latter does.

 

>What I do know is that this is par for the course with BlackBerry development.

 

I stand by my statement. Android has no such OS limitation; wherefore Blackberry? It's not like this plugin involves a simulator/emulator. Meanwhile, the *full* BB dev env works on Windows 7, Windows Vista, blah, blah, all the way back to Windows XP ( a ten-year-old OS). Google has clearly mastered something that RIM has not, working within the abstraction layer that Java/Eclipse provides.