Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Posts: 49
Registered: ‎05-06-2009
My Device: Not Specified

Again on Storm Compatibility mode

I'm compiling application in lower JDE version and running it on JDE 4.7 Storm.

Storm devices automatically run in compatibility mode...

 

I've added in the JAD attribute name, as explained in knowledge base article "DB-00710 "Compatibility mode on touch screen BlackBerry smartphones" : http://www.blackberry.com/knowledgecenterpublic/livelink.exe/fetch/2000/348583/800451/800719/What_Is...

 

I've also changed the value for those attribute from true/false to 0/1

RIM-TouchCompatibilityMode: 0

RIM-TouchCompatibilityMode-UserChangeable: 1

 

We have tested both solution with several users and OTA installation, but no way.

In every case, Storm devices runnning the app in Compatibility Mode...

The only way is the manually setting. (Go to option-> advance options-> application and Disable Compatibilty manually).

we don't want compile with 4.7 for only this thing.

 

any idea?

BlackBerry Development Advisor
Posts: 15,753
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: Again on Storm Compatibility mode

Is this a first time install or a re-install?

 

 Known Issue - Compatibility mode flags are ignored when an application is updated or reinstalled
Article Number: DB-00749

http://www.blackberry.com/knowledgecenterpublic/livelink.exe/fetch/2000/348583/800451/800719/Known_I...

 

What BlackBerry handheld software version are you testing on?  You can find this under Options, About on the BlackBerry Smartphone.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Developer
Posts: 49
Registered: ‎05-06-2009
My Device: Not Specified

Re: Again on Storm Compatibility mode

A new installation on BlackBerry 9530, device software version 4.7.0.148, doesn't work with : 

RIM-TouchCompatibilityMode: false

RIM-TouchCompatibilityMode-UserChangeable: true

 

Other users have reported the same issues also when I've changed the properties as:

RIM-TouchCompatibilityMode: 0

RIM-TouchCompatibilityMode-UserChangeable: 1

 

(I've read on this forum that the values as 0/1 are the best choice for these properties)

 

What is the best setting ?

RIM-TouchCompatibilityMode: false

or

RIM-TouchCompatibilityMode: 0

 

 

Many Thanks, Danilo.

Developer
Posts: 4,764
Registered: ‎07-21-2008
My Device: Not Specified

Re: Again on Storm Compatibility mode

We have had spotty results with disabling compatibility mode using the JAD.

 

Our call center now instructs folks to disable from the Application Settings

 

Highlighted
Developer
Posts: 91
Registered: ‎02-04-2009
My Device: Not Specified

Re: Again on Storm Compatibility mode

This won't help the original poster, but it may help others who search the forums for information about compatability mode.  I just discovered that if your Application (or UiApplication) is built with JDE 4.7.0 and overrides isInTouchCompatibilityMode so that it always returns false, the application will run normally even if the user sets it to run in compatibility mode.
Developer
Posts: 62
Registered: ‎05-29-2009
My Device: Not Specified

Re: Again on Storm Compatibility mode

I'm hitting the same problem.  I don't want to have a separate 4.7 build - anyone have any further insight?

 

Phil