Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Posts: 242
Registered: ‎02-19-2013
My Device: 9500
My Carrier: _

App not compatible with OS 7 and 7.1

I have made an app and compiled with JDE 5. But its not compatible with OS 7 and 7.1. Please help me what could be the reason for this.

 

Thanks.

Developer
Posts: 19,636
Registered: ‎07-14-2008
My Device: Not Specified

Re: App not compatible with OS 7 and 7.1

I have many apps that are compiled using OS 5.0 and run quite happily in OS 7.0 and OS 7.1.  In fact I don't think I have any that don't!

 

Can you tell us what your application is doing that works in older OS's and does not work in OS 7.0 and OS 7.1?

Developer
Posts: 242
Registered: ‎02-19-2013
My Device: 9500
My Carrier: _

Re: App not compatible with OS 7 and 7.1

[ Edited ]

This apply simply save the data this location file:///store/home/user/Databases and using the webview as well as sending the sms, making the call programmtically.

 

Please help me is it anything that making app incompatible to OS 7 and 7.1

 

Is there any settings to do to install the non market app in BB 7 and 7.1

 

Developer
Posts: 19,636
Registered: ‎07-14-2008
My Device: Not Specified

Re: App not compatible with OS 7 and 7.1

Whether you have file://store locations is device dependent and not OS dependent.  You need to check this before trying to use it.  This KB article may help:

http://supportforums.blackberry.com/t5/Java-Development/Programmatically-determine-if-a-microSD-card...

 

I presume by WebView you mean BrowserField and that exists in OS 7.0 and OS 7.1.  SMS has not changed either.

 

As noted, my experience is that the apps are compatible - let us know of anything you find that is not. 

 

Regarding installation of apps, there is no change there either.