Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Contributor
Posts: 25
Registered: ‎04-16-2010
My Device: Not Specified
Accepted Solution

App using Java SDK 5.0 compatible with lower SDK version?

[ Edited ]

Hi,

 

I wanted to know if I develop an app using the Blackberry Java SDK 5.0, would it be working on under release like 4.3 or 4.2.1? If the current application doesn't have features not available on these previous version of course.

I mean, if I develop a basic application like an HelloWorld with SDK 5.0, will this app work on a phone with SDK 4.2.1?

 

Thank you,

Damien.

Highlighted
Developer
Posts: 1,055
Registered: ‎01-25-2009
My Device: BlackBerry Bold 9650/BlackBerry Torch 9800

Re: App using Java SDK 5.0 compatible with lower SDK version?

The one time I tried it, I received a compatilbility error so I would say no from my experience.

 

My suggestion is to build with forward-compatibility in mind and remember that anything you build for 4.2 will work in 5.0 and so on.

Jerome Carty - Follow jcarty on Twitter@jcarty | #webworks-dev / #BlackberryDev on irc.freenode.net | My Apps
Click "Accept as Solution" if post solved your original issue.. Give like/thumbs up if you feel post is helpful