Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Posts: 96
Registered: ‎06-11-2009
My Device: Not Specified
Accepted Solution

Application Fails to run on 8300

Hi,

When i try to run my application on 8300 i get and error teliing that my application tries to access secure API. 

I use the following API'S

net.rim.device.api.system.PersistentObject;
net.rim.device.api.system.PersistentStore;
net.rim.device.api.util.Persistable; 

I also tried signing the application with the key and i get the following message:

no signatures required .

 I have integrated the jde with netbeans. I convert the jar file to cod file and then try signing the .cod file. Is it possible to sign the jar file directly.

 

Can someone please help me with this. Its a little urgent.

 

Thanking you,

Regards

S.A.Norton Stanley

Developer
Posts: 1,477
Registered: ‎12-30-2008
My Device: Torch 9810

Re: Application Fails to run on 8300

What are the JDE levels involved?

 

Well, Secure API needs signing.. Check the directory 

\net.rim.eide.componentpack_Version_No\components\bin

Double check if you have sigtool.* files inside it..

 

Then start the signaturetool and sign your resultant cod file..

 

Jar files cannot be signed using this..

 

Cheers.. 

--
Manimaran Selvan
Co-Founder, Tech Lead,
Equity Markets Research Group
Developer
Posts: 96
Registered: ‎06-11-2009
My Device: Not Specified

Re: Application Fails to run on 8300

Hi.

I am using JDE 4.6.0 and i have 3 sigtool.* file in my bin folder. i.e sigtool.csk,sigtool.db,sigtool.set file.

 

 

Thanking you,

Regards

S.A.Norton Stanley

Developer
Posts: 1,477
Registered: ‎12-30-2008
My Device: Torch 9810

Re: Application Fails to run on 8300

Now start your signature tool in the same directory, select your built cod file and request signatures..

 

Cheers.. 

--
Manimaran Selvan
Co-Founder, Tech Lead,
Equity Markets Research Group
Developer
Posts: 96
Registered: ‎06-11-2009
My Device: Not Specified

Re: Application Fails to run on 8300

Hi,

 

i am running the SignatureTool.jar which is in the same directory  from the command line i get the following screen

Sign Tool

 

when i request for signature i get the following(no signatures required):

After Sign

 

 

Thanking you,

Regards,

S.A.Norton Stanley

Developer
Posts: 96
Registered: ‎06-11-2009
My Device: Not Specified

Re: Application Fails to run on 8300

Hi,

 

i am running the SignatureTool.jar which is in the same directory  from the command line i get the following screen

Sign Tool

 

when i request for signature i get the following(no signatures required):

After Sign

 

 

Thanking you,

Regards,

S.A.Norton Stanley

Developer
Posts: 1,477
Registered: ‎12-30-2008
My Device: Torch 9810

Re: Application Fails to run on 8300

Follow this KB article..

http://www.blackberry.com/knowledgecenterpublic/livelink.exe/fetch/2000/348583/800989/How_to_-_Manua...

 

If that doesn't solve your problem, contact RIM - devsupport@rim.com

 

Cheers.. 

--
Manimaran Selvan
Co-Founder, Tech Lead,
Equity Markets Research Group
Developer
Posts: 1,477
Registered: ‎12-30-2008
My Device: Torch 9810

Re: Application Fails to run on 8300

See this thread too..

 

http://supportforums.blackberry.com/rim/board/message?board.id=java_dev&message.id=22261

 

This is exactly the same case..

 

Cheers.. 

--
Manimaran Selvan
Co-Founder, Tech Lead,
Equity Markets Research Group
Developer
Posts: 96
Registered: ‎06-11-2009
My Device: Not Specified

Re: Application Fails to run on 8300

Hi,

 

Thank you so much.. will contact the support people. One more question i get verification error when i run certain applications on 8300 and not on 9000. Why does that happen? And when i remove a couple of classes the application runs on 8300 without Verification error.

 

 

Thanking you,

Regards,

S.A.Norton Stanley

Highlighted
Developer
Posts: 1,477
Registered: ‎12-30-2008
My Device: Torch 9810

Re: Application Fails to run on 8300

You can resolve this thread and put up a new thread..

 

Cheers.. 

--
Manimaran Selvan
Co-Founder, Tech Lead,
Equity Markets Research Group