Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.

Posts: 105
Registered: ‎05-22-2008
My Device: Not Specified

ApplicationPermission on JDE4.6.0 :- Keeps asking for device reboot ?

I have an app developed in JDE 4.2.1, that uses the ApplicationPermission class to check current permissions,

and ask the user via the invokePermissionsRequest() API call, for missing permissions.


This works GREAT in 4.2.xxx, and the user is prompted , and then presented with new permissions.

The user has to then "Save" the new permissions, and then the application works, without showing any

security dialogs on network access etc..


So far so good..


Now, when the same application is run on a BOLD or (another device running 4.3), the following happens :-


On OTA download :-


1.  First the user gets a prompt :- Would you like to grans App Trusted app status ---> YES


2.  Next :- App is requesting changes to its application control permissions (invokePermissionsRequest()) ---> View


3.  Then a permissions screen is shown , and I select "Save" from the menu.


4.   Next :- Dialog "Permission setting have become more restrivtive.. Device must be reset . Notive 1 of 5"


Ok, I reboot



Then I launch the app by clicking its icon.


I am back at


.........Step 2


followed by


..........Step  3


followed by

.........Step 4


and this keeps on happening  !!!


Any idea what has changed in O/s 4.6.0 to break this ????






Posts: 283
Registered: ‎07-22-2008
My Device: Not Specified

Re: ApplicationPermission on JDE4.6.0 :- Keeps asking for device reboot ?

I was ( and still) getting the same behavior. When I compiled on the same version as the phone (i.e. 4.6) it worked fine.

My own explanation to this is that there are some incompatibilities in the AppPermission class. I know that they have added, renamed and combined flags in the new version. That could be the problem.


For now I had to relax my conditions and check for the "Deny" only. What used to require "Allow" permission is changed to check for not "Deny" only. This way I (pseudo) got around the problem.


Please let us know if you have a better work around.





Posts: 105
Registered: ‎05-22-2008
My Device: Not Specified

Re: ApplicationPermission on JDE4.6.0 :- Keeps asking for device reboot ?

I get the same error even when I compile with JDE 4.6.0.


The only work around that works for me, is if I select "Expand All " before "Save" when the permissions are displayed.


I am requesting at least 5 permissions.


I still have to compile the JDE sample and test.