Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development


Thank you for visiting the BlackBerry Support Community Forums.

BlackBerry will be closing the BlackBerry Support Community Forums Device Forums on April 1st (Developers, see below)

BlackBerry remains committed to providing excellent customer support to our customers. We are delighted to direct you to the CrackBerry Forums, a well-established and thorough support channel, for continued BlackBerry support. Please visit http://forums.crackberry.com or http://crackberry.com/ask. You can also continue to visit BlackBerry Support or the BlackBerry Knowledge Base for official support options available for your BlackBerry Smartphone.

"When we launched CrackBerry.com 10 years ago, we set out to make it a fun and useful destination where BlackBerry Smartphone owners could share their excitement and learn to unleash the full potential of their BlackBerry. A decade later, the CrackBerry community is as active and passionate as ever and I know our knowledgeable members and volunteers will be excited to welcome and assist more BlackBerry owners with their questions."

- Kevin Michaluk, Founder, CrackBerry.com

Developers, for more information about the BlackBerry Developer Community please review Join the Conversation on the BlackBerry Developer Community Forums found on Inside BlackBerry.


Reply
Contributor
Posts: 45
Registered: ‎12-27-2011
My Device: Developer
My Carrier: None

BBM integration verification failed

I'm trying to do bbm integration with the alternative dependency checker, but not getting anywhere near the expected results..

 

As simulator i am using the torch and the bold from this url
http://us.blackberry.com/developers/blackberrymessenger/

And I'm following the getting started and development guidelines from her http://docs.blackberry.com/en/developers/subcategories/?userType=21&category=BlackBerry+Messenger+So...

 

If i try to run the app in the 9800 torch bbm enabled simulator it says wrong jvm but keeps running, when i run the app the getinstance always returns null like it fails to add the persistent object (no exception is thrown though).

 

In the 9900 bold simulator it looks like its running smoothly, I get a dialog asking me if i want to connect the app to bbm. If I choose to connect it then it wants to verify my app.

After several minutes it fails and I see the following error message in the out´put console:

[128.656] BbiAuth:ERR:net.rim.device.api.crypto.bbiauth.BbiAuthException: No BBAuth service record configured

 

Note: My app only needs to set the profile personal message and not interact between 2 contacts, therefore I am running the simulator from eclipse with the custom commandline mentioned in the getting started guideline.

Developer
Posts: 19,636
Registered: ‎07-14-2008
My Device: Not Specified

Re: BBM integration verification failed

Does it work if you use the Simulators supplied with BBM?

Contributor
Posts: 45
Registered: ‎12-27-2011
My Device: Developer
My Carrier: None

Re: BBM integration verification failed

Ok so i found out that the problem must be with the internet connection through the MDS simulator

The 9800 bbm enabled simulator has internet just fine through the MDS sim.

In the getting started guide there is a custom commandline for the 9800 which i copied and edited for the 9900

So my guess is that this custom commandline is wrong.

The commandline i put for the 9900 is:

 

"C:\Program Files (x86)\Research In Motion\BlackBerry Smartphone Simulators 7.0.0\7.0.0.236 (9900)\fledge.exe" /handheld=9900 /app-param=JvmAlxConfigFile:9900.xml /pin=0x2100000A /data-port=0x4d44 /data-port=0x4d4e /session=9900 /app="C:\Program Files (x86)\Research In Motion\BlackBerry Smartphone Simulators 7.0.0\7.0.0.236 (9900)\Jvm.dll" /app=Jvm.dll /handheld=9900 /session=Sim1 /app-param=JvmAlxConfigFile:9900.xml /data-port=0x4d44 /data-port=0x4d4e /pin=0x2100000A /app-param=regVersion=3 /app-param=regDestIP=127.0.0.1 /app-param=regDestPort=19781 /app-param=regSrcPort=19780 /app-param=DisableSyncServiceRecord /title="BlackBerry 9900-1 Simulator"

Contributor
Posts: 45
Registered: ‎12-27-2011
My Device: Developer
My Carrier: None

Re: BBM integration verification failed

i tried 2 of the 3 supposedly bbm enabled simulators mentioned here
http://us.blackberry.com/developers/blackberrymessenger/

BlackBerry® Torch™ 9800 (6.0.0.313) and BlackBerry® Bold™ 9900 (7.0.0.236)
Highlighted
Contributor
Posts: 45
Registered: ‎12-27-2011
My Device: Developer
My Carrier: None

Re: BBM integration verification failed

ok so i think im one step closer to figuring out what is wrong with mds

apparently the version of the mds simulator shipping with the eclipse plugin doesn't work with OS 7.x?

 

can anyone point me to a download of a version that does?