Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Contributor
Posts: 49
Registered: ‎12-16-2010
My Device: 9700
My Carrier: Vodafone

BIS Application loses connection after 10 sg

Hi, 

 

I am developing a SIP application

 

When using BIS I see the TLS channel is closed after 10 seconds

 

On the logs I see there is a PDP State change:

INFO 12:52:33:097 : *****[ConnectionManager] pdpStateChange APN:3 state:2 cause: 33 *****/

 

I see reason 33 means: PDP_CAUSE_SERVICE_NOT_SUBSCRIBED despite i'm connecting with BIS

The issue is not happening when using carrier APN.

 

How can I fix this?

 

 

Developer
Posts: 16,992
Registered: ‎07-29-2008
My Device: Z10 LE, Z30, Passport
My Carrier: O2 Germany

Re: BIS Application loses connection after 10 sg

maybe bbry closes the connection because you are not allowed to use bis. just a theory.
----------------------------------------------------------
feel free to press the like button on the right side to thank the user that helped you.
please mark posts as solved if you found a solution.
@SimonHain on twitter
Contributor
Posts: 49
Registered: ‎12-16-2010
My Device: 9700
My Carrier: Vodafone

Re: BIS Application loses connection after 10 sg

Hi Simon

 

Still not asked to BB Alliance because first I want to test how the app is working with BIS, then if it works properly we will submit it to BB Alliance

 

i am using the magic connection string for the testnig. Isn't that enough now?