Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Contributor
Posts: 15
Registered: ‎06-06-2011
My Device: BlackBerry Curve 9300
My Carrier: Personal
Accepted Solution

BlackBerry Curve 9300 JDE

Hi, I'd like to know which JDE should I download to write, test and debug a program for a BlackBerry Curve 9300.  I've already tried with JDE 6, JDE 5 and JDE 4.7 and in none of them is the 9300 device to choose for debug or deploy. 

 

Thanks in advence

Developer
Posts: 298
Registered: ‎05-02-2010
My Device: Bold 9700
My Carrier: Verizon

Re: BlackBerry Curve 9300 JDE

You can download the 9300 Simulator here: http://us.blackberry.com/developers/resources/simulators.jsp under "Select your smartphone:" and use whichever JDE 6 or 5 you'd like.

--Todd

Windows 7 Enterprise 64-bit (6.1 Build 7600) | Java SE Runtime Environment (build 1.6.0_24-b07) | Eclipse Version: 3.6.2 [M20110210-1200] | BlackBerry Eclipse Plug-in: 1.3.0.201102031007-19 | Java Compiler level: 1.3 | Targeting devices running OS 5 | Simulators: JDE 5.0 packaged 9700, 9630, 9300
Contributor
Posts: 15
Registered: ‎06-06-2011
My Device: BlackBerry Curve 9300
My Carrier: Personal

Re: BlackBerry Curve 9300 JDE

Todd,

Thanks for your response.  Already did that, but I cant add the device to the JDE in order to launch the application from the IDE.  JDE 6 comes with 9800 as simulator device.  I would like to be able to launch the application from inside the IDE to the 9300 device.  I tried to load the application from the simulator and it didnt worked.  Is there a way to add the device to the JDE?

 

Kind Regards and thanks again for your response.

Developer
Posts: 109
Registered: ‎12-04-2008
My Device: Playbook, Torch 9800, Storm 9530, Tour 9630
My Carrier: Telus

Re: BlackBerry Curve 9300 JDE

[ Edited ]

Were you able to load this? The simulator package with the 9300 OS 6 is the second one under the Generic heading...,

B

PlayBook Apps: Sudoku Pro
Smartphone Apps: Compass | MultiClock
Developer
Posts: 61
Registered: ‎08-12-2011
My Device: Curve 8520

Re: BlackBerry Curve 9300 JDE

[ Edited ]

I think you have to set the version of the JDE you want to use when you create your application, unless you can change it in the 'app descriptor' XML file.

 

I recently installed the Java Development Kit 5.0 so I could simulate my 8520 (or another OS 5 device) and that seemed to have integrated in to Eclipse Helios, where by default it had an OS 6 device for the simulator, but now I can debug apps on OS 5 and OS 6.

Highlighted
Contributor
Posts: 15
Registered: ‎06-06-2011
My Device: BlackBerry Curve 9300
My Carrier: Personal

Re: BlackBerry Curve 9300 JDE

Im using NetBeans with a plugin for Blackberry development. What Im doing is to build my app inside NB, then load the app from inside the simulator and run it there.  When I need to debug it, I open BB JDE, open simulator and attach debuger to simulator. Kind of tricky, but is working.  I dont use Eclipse at all, so I didnt want to install it.  Hope you manage to get this working. 

As for the other post, In NB you can set the target OS in the project properties, and you can change it at will.

 

Regards,