Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
New Developer
Posts: 14
Registered: ‎08-14-2009
My Device: Not Specified

BlackBerry JDE Bluetooth support

I am compiling my project in BlackBerry JDE 4.2.0

My project uses JSR 82 Bluetooth APIs

When I compile I get error:

"package javax.bluetooth does not exist"

Then I added file "C:\WTK2.5.2\lib\jsr082.jar" to imported jar files of project.

Then I compile and I got error:

"Error!: Duplicate definition for 'javax.obex.Authenticator' found in: javax.obex.Authenticator"

 

Please tell me how to compile.

 

Thanks in advance

Highlighted
Developer
Posts: 1,807
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.3.2.858, Z10 (STL100-3)-10.3.1.2576, Z30 (STA100-5)-10.3.1.2582, Passport (SQW100-1)-10.3.1.2576, PlayBook (16GB)-2.1.0.1917
My Carrier: Verizon

Re: BlackBerry JDE Bluetooth support

[ Edited ]
I don't know what specific version Bluetooth was introduced but 4.5 and up supports it.
Message Edited by rcmaniac25 on 08-26-2009 01:45 PM
---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
Developer
Posts: 984
Registered: ‎02-10-2009
My Device: Not Specified

Re: BlackBerry JDE Bluetooth support

Have you checked the sample bluetoothsample that is shipped with the JDE.

 

Regards

Bikas

New Developer
Posts: 14
Registered: ‎08-14-2009
My Device: Not Specified

Re: BlackBerry JDE Bluetooth support

http://www.blackberry.com/knowledgecenterpublic/livelink.exe/fetch/2000/348583/800738/800901/What_Is...

Above document says "you should use a BlackBerry JDE version that matches the lowest version of BlackBerry Device Software you want to support"
and I want to support from OS version 4.2.0
thats why I am using JDE 4.2.0

I checked bluetoothsample in JDE but it doesn't use JSR 82 but blackberry specific APIs
The application on which I am working is already developed using JSR 82.

New Developer
Posts: 14
Registered: ‎08-14-2009
My Device: Not Specified

Re: BlackBerry JDE Bluetooth support

The application is compiling fine on JDE 4.2.1

Is it that JSR 82 is not supported on JDE 4.2.0 ?