Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Developer
Posts: 45
Registered: ‎06-23-2010
My Device: Not Specified

Re: BlackBerry Java Plug-in for Eclipse 1.3.0 released!

I still hope you will provide Linux version... Smiley Happy

Developer
Posts: 155
Registered: ‎01-22-2010
My Device: PlayBook -> 9900, 9810, 9800, 9700,9000, 8800, 8700...
My Carrier: AT&T

Re: BlackBerry Java Plug-in for Eclipse 1.3.0 released!

kay, this was in part user error - i forgot that username/pass was required. however, i seem to recall being prompted for that info under 3.5; but 3.6 is not (eclipse issue or change, not the plugin)



Try out BBSSH, a free Blackberry SSH client.
  • If you like my post, please let me know by Liking it!
  • If my post solved your problem please click on the Accept as Solution button.

Developer
Posts: 207
Registered: ‎09-10-2010
My Device: Not Specified

Re: BlackBerry Java Plug-in for Eclipse 1.3.0 released!

How do I upgrade from 1.1.2 to 1.3.0 ?  Eclipse > Help > "Check for updates" says there is nothing to update.  Does that mean I have to install another plug-in 1.3..0 (doesn't sound good)  or uninstall 1.12 and then install 1.3.0? There should be some way to update.

Developer
Posts: 242
Registered: ‎01-29-2009
My Device: Not Specified

Re: BlackBerry Java Plug-in for Eclipse 1.3.0 released!

I don't think you will be able to just upgrade.

 

Plugin 1.1.2 requires Eclipse 3.5

Pluing 1.3.0 requires Eclipse 3.6

Developer
Posts: 207
Registered: ‎09-10-2010
My Device: Not Specified

Re: BlackBerry Java Plug-in for Eclipse 1.3.0 released!

Oops...my bad!!..I didn't notice Smiley Sad 3.6. Thanks.

Developer
Posts: 604
Registered: ‎12-27-2010
My Device: Not Specified

Re: BlackBerry Java Plug-in for Eclipse 1.3.0 released!

Does anyone know what the requirements are for the "Version" attribute in the Application Descriptor now? I used to be able to append info to designate beta builds (b1, b2, etc) but it complains about that now.

Developer
Posts: 242
Registered: ‎01-29-2009
My Device: Not Specified

Re: BlackBerry Java Plug-in for Eclipse 1.3.0 released!

Looks like this new plugin still suffers the same problem with additionally installed simulators on Win 7 (64-bit) as reported here earlier on:

 

http://supportforums.blackberry.com/t5/Java-Development/No-addtionally-installed-Simulators-availabl...

Developer
Posts: 604
Registered: ‎12-27-2010
My Device: Not Specified

Re: BlackBerry Java Plug-in for Eclipse 1.3.0 released!

They work for me. Had to restart it once, but they showed up.

Developer
Posts: 242
Registered: ‎01-29-2009
My Device: Not Specified

Re: BlackBerry Java Plug-in for Eclipse 1.3.0 released!

Restart Eclipse or Windows? I tried Eclipse but no luck.

 

Under what path do you have the simulators installed?

Highlighted
Developer
Posts: 292
Registered: ‎07-25-2008
My Device: Passport

Re: BlackBerry Java Plug-in for Eclipse 1.3.0 released!

Okay, here's my first annoying (possibly showstopper) issue with the v1.3 plugin...

 

I have a library built against BlackBerry JRE 4.5, called Foo.

I have another library built against BlackBerry JRE 4.6, called Foo_BB46.

Foo_BB46 depends on Foo.

 

When trying to launch the simulator, I get the following error as it tries to package Foo_BB46:

 

C:\Eclipse\plugins\net.rim.ejde.componentpack4.6.0_4.6.0.23\components\lib\net_rim_api.jar(net_rim_bb_addressbook.cod): Error!: Duplicate definition for 'net.rim.device.apps.api.addressbook.AddressBook' found in: C:\Eclipse\plugins\net.rim.ejde.componentpack4.5.0_4.5.0.28\components\lib\net_rim_api.jar(net_rim_bb_addressbook.cod)