Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
BlackBerry Development Advisor
Posts: 15,784
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: BlackBerry Java SDK v7.0 Beta Released


smiley wrote:

Mark, is there a doc that list what is new in OS7? looking at the javadoc it is hard to tell what is new in OS7.

 

thx


There is a "New in this release" document, which can be found here:  http://docs.blackberry.com/en/developers/deliverables/29270/New_in_BB7_1644396_11.jsp

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Developer
Posts: 1,006
Registered: ‎05-22-2009
My Device: Not Specified

Re: BlackBerry Java SDK v7.0 Beta Released

HI Mark ,In my XP device,I am using correct username and password,I tried login  to site you pointed,,to confirm ,yes it is correcct,but here while downloading while asks for login.if i do it for 2 or 3 times,it is working,or it doesnt accept password for first time and one more thing do i need to require to set up configured my proxy server within Eclipse,I didnt do it for previous downloads,It was downloading for previous versions.If required,how to do it?

 

 

Regards

 

Rakesh Shankar.P

BlackBerry Development Advisor
Posts: 15,784
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: BlackBerry Java SDK v7.0 Beta Released

Do you have a proxy configured in your browser?  This page shows how to configure a proxy in Eclipse:  http://www.roseindia.net/eclipse/eclipse-update-proxy.shtml

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Developer
Posts: 709
Registered: ‎09-10-2009
My Device: 8520, 8900, 9000, 9300, 9650, 9700, 9780, 9800, 9810, 9900, 9930
My Carrier: Verizon

Re: BlackBerry Java SDK v7.0 Beta Released

What are the possible BB models will likely to support OSv7?

BlackBerry Development Advisor
Posts: 15,784
Registered: ‎07-09-2008
My Device: BlackBerry PRIV
My Carrier: Bell

Re: BlackBerry Java SDK v7.0 Beta Released

To date we have announced that the BlackBerry Bold 9900 and BlackBerry Bold 9930 will be running 7.0.

Mark Sohm
BlackBerry Development Advisor

Please refrain from posting new questions in solved threads.
Problem solved? Click the Accept As Solution button.
Found a bug? Report it using Issue Tracker
Developer
Posts: 709
Registered: ‎09-10-2009
My Device: 8520, 8900, 9000, 9300, 9650, 9700, 9780, 9800, 9810, 9900, 9930
My Carrier: Verizon

Re: BlackBerry Java SDK v7.0 Beta Released

[ Edited ]

What about the existing models like the 9800 and the 9780? Both models has 512MB ram but the processors are slower.

Highlighted
Developer
Posts: 1,807
Registered: ‎04-28-2009
My Device: Z10 (STL100-4)-10.3.2.858, Z10 (STL100-3)-10.3.1.2576, Z30 (STA100-5)-10.3.1.2582, Passport (SQW100-1)-10.3.1.2576, PlayBook (16GB)-2.1.0.1917
My Carrier: Verizon

Re: BlackBerry Java SDK v7.0 Beta Released

Unfortunetly: http://blog.wirelessground.com/blackberry-os-7-not-backwards-compatible/

---Spends time in #blackberrydev on freenode (IRC)----
Three simple rules:
1. Please use the search bar before making new posts.
2. "Like" posts that you find helpful.
3. If a solution has been found for your post, mark it as solved.
--I code too much. Well, too bad.
Developer
Posts: 709
Registered: ‎09-10-2009
My Device: 8520, 8900, 9000, 9300, 9650, 9700, 9780, 9800, 9810, 9900, 9930
My Carrier: Verizon

Re: BlackBerry Java SDK v7.0 Beta Released

That's not what I was asking.

 

I was asking will OSv7 will eventurally run on those models.

Developer
Posts: 119
Registered: ‎05-27-2010
My Device: 9900
My Carrier: Vodafone NL

Re: BlackBerry Java SDK v7.0 Beta Released

OS7 will not be available for current in market devices. From a developer standpoint your code made in 4.5 4.6 4.7 5.0 6.0 SDK's will work nicely in 7. So no 7 for a 9780 or 9800.
Most of the new features in the 7.0 SDK are dependent on the new hardware and therefore make no sense to deploy on the current 6.0 devices.
(Nfc, compass, opengl, etc.)
I understand its an abrupt change, but unfortunatly progress sometimes comes at a cost and the current jump to the new much better hardware requires to much changes to the OS that have no relevance to the former hardware platforms.
I hope this answers your question.
@reumerd-- @BBDevGroupNL -- about me
If you like it, LIKE it ;-) ----- If it's solved, press solved ! --- If you solved it yourself, please let us know! We might have the same problem!
Developer
Posts: 1,178
Registered: ‎02-19-2009
My Device: Not Specified

Re: BlackBerry Java SDK v7.0 Beta Released

 

I agree


reumerd wrote:
OS7 will not be available for current in market devices. From a developer standpoint your code made in 4.5 4.6 4.7 5.0 6.0 SDK's will work nicely in 7. So no 7 for a 9780 or 9800.
Most of the new features in the 7.0 SDK are dependent on the new hardware and therefore make no sense to deploy on the current 6.0 devices.
(Nfc, compass, opengl, etc.)
I understand its an abrupt change, but unfortunatly progress sometimes comes at a cost and the current jump to the new much better hardware requires to much changes to the OS that have no relevance to the former hardware platforms.
I hope this answers your question.

Completely agree, no problem in changes, I hope that this new phones will help blackberry to better compete in the smartphones war.

I develop on all platforms but I don't like apple policy, google is indifferent since I make too few money on it to worth liking it, come on RIM!