Welcome!

Welcome to the official BlackBerry Support Community Forums.

This is your resource to discuss support topics with your peers, and learn from each other.

inside custom component

Java Development

Reply
Contributor
Posts: 43
Registered: ‎11-14-2011
My Device: Cure 9300 3G
My Carrier: Vodacom South Africa

BlackBerry Simulator has encountered a problem

[ Edited ]

Hello

 

I am running Eclipse 3.7.2 with the BlackBerry Java Plug-in 1.5.2 and component pack 5.0.0.36.

 

I added one of the default Simulators, 9700, to my Debug Configurations and clicked debug. I get the error on the screen shot. Please assist.

 

Eclipse Plugin Error

 

I downloaded and installed Eclipse first. Then installed the BlackBerry Java Plug-in via the Eclipse update site at http://www.blackberry.com/developers/jar/win/java.

 

I have also modified the Eclipse to only run on jdk.1.6.0_32 by modifying the eclipse.ini file:

 

-vm
C:\Program Files\Java\jdk1.6.0_32\bin\javaw.exe



Hendré

Developer
Posts: 19,636
Registered: ‎07-14-2008
My Device: Not Specified

Re: BlackBerry Simulator has encountered a problem

Just to add weight to this I get this with some of the default Simulators, but not with some I have added.  Haven't done any analysis to determine if there is any correlation.  Hope that that someone can chip in with a reason.  

Contributor
Posts: 43
Registered: ‎11-14-2011
My Device: Cure 9300 3G
My Carrier: Vodacom South Africa

Re: BlackBerry Simulator has encountered a problem

This seems to be a memory problem. I increased the maximum heap space in the eclipse.ini file to 1024 and managed to start the 9550 Simulator.